Note: There are a few cases of duplicates in user autocompletion which are being worked on.

0* frame displays as non-zero size in older browsers

VERIFIED FIXED in M17

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: b rees, Assigned: Eric Pollmann)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] fix in hand wdormann@crosswinds.net, URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
For some reason mozilla cannot display this site:  www.slickedit.com.  All I
see in the browser is a graphic on the left side which appears to corresond
to only one part of the frame set.

Comment 1

17 years ago
Confirmed.   Making test case.
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLFrames
Ever confirmed: true
Keywords: makingtest
OS: Windows NT → All
Whiteboard: wdormann@crosswinds.net

Comment 2

17 years ago
Created attachment 9119 [details]
Simplified testcase

Comment 3

17 years ago
The above testcase is a simplified version of the frameset in question.    I
think I could have simplified it more, but I'm not sure at what point it stops
being valid syntax.       This case shows 3 frames, 3 picture in Netscape.
Only the first frame/picture is displayed in Mozilla.

Comment 4

17 years ago
Sorry for spam.  Forgot to reset Keyword.
Keywords: makingtest → testcase

Comment 5

17 years ago
reassigning.
Assignee: asa → pollmann
QA Contact: jelwell → petersen
(Assignee)

Comment 6

17 years ago
Funny, I specifically fixed this type of page not too long ago:

<FRAMESET cols="147,0*" rows="*">

This means "A column of 147 pixels followed by a frame of 0 pixels.", according 
to HTML 4.0 Section 6.6 states:
 3. MultiLength: The value ( %MultiLength; in the DTD) may be a %Length; or a 
    relative length. A relative length has the form "i*", where "i" is an 
    integer. When allotting space among elements competing for that space, user
    agents allot pixel and percentage lengths first, then divide up remaining 
    available space among relative lengths. Each relative length receives a 
    portion of the available space that is proportional to the integer preceding 
    the "*". The value "*" is equivalent to "1*". Thus, if 60 pixels of space
    are available after the user agent allots pixel and percentage space, and
    the competing relative lengths are 1*, 2*, and 3*, the 1* will be alloted 10 
    pixels, the 2* will be alloted 20 pixels, and the 3* will be alloted 30
    pixels.

I can fix this to be backwards compatible in quirks mode, but the page should 
probably be changed to:

<FRAMESET cols="147,*" rows="*">

To achieve the desired effect in standards compliant browsers.
Status: NEW → ASSIGNED
Keywords: 4xp
Summary: page does not display beyond left frame set → 0* frame displays as non-zero size in older browsers
(Assignee)

Comment 7

17 years ago
Nav and IE treat 0* as 1*.  I have a fix in my tree that makes this so iff we 
are in quirks mode.
Whiteboard: wdormann@crosswinds.net → fix in hand wdormann@crosswinds.net
(Assignee)

Updated

17 years ago
Target Milestone: --- → M17

Comment 8

17 years ago
*** Bug 43921 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
(updating mutiple bugs)

Nominating this bug for beta3 because it is either a crasher or a correctness 
bug and I have a straightforward fix in hand.  This bug fix is small, low risk, 
and can easily be reverted with no side effects.
Keywords: nsbeta3
Marking nsbeta3+
Whiteboard: fix in hand wdormann@crosswinds.net → [nsbeta3+] fix in hand wdormann@crosswinds.net
(Assignee)

Comment 11

17 years ago
This fix has been checked in.  Coming up with a test case to assist in
verification...
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
Marking verified in the Aug 24th build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.