page-break-before: always and page-break-inside: avoid is not honored on divs with complex content leading to print pages with missing content

RESOLVED DUPLICATE of bug 132035

Status

()

RESOLVED DUPLICATE of bug 132035
11 years ago
10 years ago

People

(Reporter: twohey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007111404 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007111404 Minefield/3.0b2pre

When I go to the URL above, each bracket should be on it's own page. This is very much not the case with Firefox 2.0 (it simply displays the footer) and with the latest Minefield the situation is not much better, it cuts off the brackets after the first page.

Opera handles things correctly.

Reproducible: Always

Steps to Reproduce:
1. Load the URL
2. Print

Actual Results:  
Notice that
   (A) each bracket is NOT on a separate page
   (B) the bracket list is cut off

Expected Results:  
(A) each bracket would be on a separate page
(B) ALL the brackets would print

Safari 2.0 gets this wrong as well, not setting the page breaks properly and cutting brackets across two pages, BUT it does print all of them.

Opera handles the situation correctly.

I asked a friend with Windows to look at this and it appears the issue happens on Windows as well.

It appears that there are other bug reports dealing with printing and page breaks, but they either needed more information or seemed to address different issues, so I don't think this is a dup.

There was no printing component, so I filed this under general

Comment 1

10 years ago
This functionality is simply not available yet, but that's already known.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 132035
You need to log in before you can comment on or make changes to this bug.