Closed Bug 403937 Opened 12 years ago Closed 11 years ago

Missing title on Mac for "about Mozilla Firefox" Window

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: cbook, Unassigned)

Details

Attachments

(1 file)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

The About Mozilla Firefox Window has no titel (on windows its named as about Mozilla Firefox).

This cause the problem that you have empty entry when you have this window open and you select this window from the dock, see screenshot
Is this by design? We even don't have a window title in Firefox 2.
indeed
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
verified
Status: RESOLVED → VERIFIED
(In reply to comment #0)
> This cause the problem that you have empty entry when you have this window open
> and you select this window from the dock, see screenshot

There's still a bug here, it's just not listed in the summary. It's the behavior I've quoted above from this bug's description, which I just reproduced on the trunk.

(The Apple HIG says that About windows should not be listed in the Window menu. I would infer from that, that they shouldn't be listed in the Dock's window menu either, and in fact that is how Safari behaves.)

IMO this bug should be reopened, and the summary changed to something like "About window appears in Dock menu with no title"... (Well, either that, or maybe I should file a new bug.)
Barry, please file a new bug with the link to the appropriate HIG article. Thanks.
You need to log in before you can comment on or make changes to this bug.