Closed Bug 404015 Opened 12 years ago Closed 12 years ago

The Password Manager dialog's list selection changes when pressing Escape

Categories

(Toolkit :: Password Manager, defect, P4, minor)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: ehsan, Assigned: ehsan)

References

()

Details

(Keywords: polish)

Attachments

(1 file)

Steps to reproduce:

1. Open Password Manager.  Initially, the passwords list has no selection.
2. Press Escape.  The first item in the list gets selected.
3. Press Escape again.  The selection disappears.
4. Continuing to press Escape toggles the selection state of the passwords list.

This happens because the code in <http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/components/passwordmgr/content/passwordManager.js&rev=1.18&mark=310-313#310> does not check if the search box is empty before calling |SignonClearFilter|.  The fix should be simple: call |SignonClearFilter| only if the pressed key is the Escape key and the search box is not empty.
Flags: blocking-firefox3?
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Priority: -- → P4
Attached patch Patch (v1)Splinter Review
Trivial patch to fix the problem.
Attachment #292330 - Flags: review?(mconnor)
Comment on attachment 292330 [details] [diff] [review]
Patch (v1)

Asking mano to review...
Attachment #292330 - Flags: review?(mconnor) → review?(mano)
Attachment #292330 - Flags: approval1.9?
Attachment #292330 - Flags: approval1.9? → approval1.9+
Checking in toolkit/components/passwordmgr/content/passwordManager.js;
/cvsroot/mozilla/toolkit/components/passwordmgr/content/passwordManager.js,v  <--  passwordManager.js
new revision: 1.23; previous revision: 1.22
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.