"ASSERTION: Unexpected index" with XBL and <xul:listcell>

VERIFIED DUPLICATE of bug 403962

Status

()

defect
VERIFIED DUPLICATE of bug 403962
12 years ago
10 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks 2 bugs, {assertion, testcase})

Trunk
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

605 bytes, application/xhtml+xml
Details
Reporter

Description

12 years ago
Posted file testcase
Loading the testcase triggers:

###!!! ASSERTION: Unexpected index: 'PRUint32(index) == singleIndex', file /Users/jruderman/trunk/mozilla/content/xbl/src/nsBindingManager.cpp, line 1384
The patch in bug 403962 will fix this (for one thing, it'll remove this assertion, which is firing for the expected reasons here: the correct nested insertion point is not the same as the outermost single insertion point, and has a totally different index).
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 403962
Reporter

Comment 2

12 years ago
The testcase doesn't trigger any assertions now that bug 403962 is fixed :)

Boris, should/did this testcase go into the test suite?
Status: RESOLVED → VERIFIED
It hasn't, but since the assert got removed there's nothing to really test...
Reporter

Comment 4

12 years ago
Does it still test a code path not covered by other tests?
Probably, if other tests don't include xul:listcell elements.  If they do, I have no idea.

In general, I would assume that any given file tests a codepath not tested by other files, since we have so many codepaths.
Reporter

Comment 6

10 years ago
Added crashtest:
http://hg.mozilla.org/mozilla-central/rev/63120a5301f2
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.