Closed Bug 404166 Opened 15 years ago Closed 12 years ago

"always perform this action" doesn't work when Content-Disposition:attachment is used

Categories

(Core Graveyard :: File Handling, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 453455

People

(Reporter: artparmet, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.9) Gecko/20071030 Firefox/2.0.0.9 SeaMonkey/1.1.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.9) Gecko/20071030  SeaMonkey/1.1.6

Downloads from sites that specify Content-Disposition:attachment always result in a dialog asking the user what to do. The "always perform this action" option is grayed out and the directive options always default to "save it to disk". 

This will be the case even if the user sets the options for automatic operation and a helper app in Preferences / Helper Applications for the specific MIME type.

Reproducible: Always

Steps to Reproduce:
1. Download a file from a financial institution such as Bank of America which encodes their Quicken .qfx files as Content-Disposition:attachment.
Actual Results:  
A dialog always appears asking for action desired. Options previously set in Preferences / Helper Applications for the specific MIME type are ignored.

Expected Results:  
If the user has chosen to invoke a helper application for this MIME type and do it automatically (Preferences / Helper Applications), this dialog should be bypassed. Essentially, "attachment" disposition should be handled like "inline" at the users' discretion.

Also, the MIME type option selections in Preferences / Helper Applications should "stick" for this disposition:attachment type. 

This syndrome has been discussed at length in Bug 236541 (core) and Bug 331259 (FF  / Download Manager on PC). This request is specific to the UI on SM on Mac OSX.

On OSX, the file download occurs independent of the action selected. This behavior is OK and should be left intact for potential site compatibility issues. It should be noted that on the PC platform, downloads that invoke helper applications do not save the file.

Screen snapshots of the dialog can be provided.
Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.1 Branch
Yes,
This is reproducible on SM v1.1.9.
Assignee: download → nobody
Component: Download & File Handling → File Handling
Product: SeaMonkey → Core
QA Contact: file-handling
Version: SeaMonkey 1.1 Branch → unspecified
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.