child menus from dropdown parents showing inconsistent active state.

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
11 years ago
4 years ago

People

(Reporter: Ed Hume, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111805 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111805 Minefield/3.0b2pre

Because I make themes for people with visual impairments, I provide distinct feedback whenever an item in chrome is hovered over (:hover and [_moz-menuactive="true"]) and clicked-on (:hover:active and [_moz-menuactive="true"]:active). I skin the menus and menuitems in the menu bar and in the dropdown menus of the context menus, the menu bar and bookmarks. I also skin the icons of every native menu and menuitem except for the main entries on the menu bar.

In fx2, the icons and the background colors change when they are hovered over or clicked on. In fx3, there is inconsistency in the behavior of the View > Sidebar > [selections] child menu and the View > Zoom > [selections] child menu.

In the View > Sidebar child menus, the first time or two you click on Bookmarks or History, you will see the icon and background color changes. Then you will see only the hover changes; the active changes stop happening for both icons and background color.

Interestingly, when you click on a selection in the child menu, the parent menu shows the active state in both icon and background. This is normal behavior, but it shows that the system is responding to the click.

In the View > Zoom child menu, generally the Zoom In and Reset menuitems show the active effects, but not always. Sometimes the Zoom Out shows the active state, but then stops doing so. The behavior is inconsistent.

In the main window context menu, when a frame is present, the context > This Frame > View Frame Info menuitem does not show changes when it is clicked on, though the parent This Frame menuitem does show the changes.


Reproducible: Always

Steps to Reproduce:
1. Install SphereGnome or SphereGnome_Big (preferably the latter)
2. Choose to use the theme; restart Firefox.
3. Click on a menuitem in View > Sidebar or View > Zoom; or go to gmail, right-click on the mail list, and click on This Frame > View Frame Info.
Actual Results:  
Selected menuitems fail to show active state changes.

Expected Results:  
Selected menuitems should show active state changes.

The initial coding for the icons was :hover:active. This was changed to [_moz-menuactive="true"]:active in an attempt to respond to the failure to show :active changes.

I have also tried :active alone, without :hover or [_moz-menuactive="true"] in the code for those items.

The code for the active menuitem backgrounds is in menu.css. The code for the menuitem icons is in menuIcons.css.

The version of SphereGnome that has coding for Zoom (fx2 was enlarge and reduce text size) is here:

http://www.pshrink.com/firebird/spheregnome-2.3-fx.jar

I will post a copy of SphereGnome_Big in a few minutes. The two differ in that SphereGnome_Big has separate hover states for almost all icons, where SphereGnome generally has only normal and active.
(Reporter)

Comment 1

11 years ago
Location of SphereGnome_Big coded for fx3:

http://www.pshrink.com/firebird/spheregnome_big-2.3-fx.jar

Mozillazine thread on this topic, with confirmation of the bug:

http://forums.mozillazine.org/viewtopic.php?t=603802
Confirming.  I see the same thing.
(Reporter)

Comment 3

10 years ago
FormalGnome, which lacks menu icons and is a normal sized theme, is also experiencing failure of child menu lines to show changes on active state.

This is a regression from Firefox 2.

mcdavis941, can you mark this as confirmed, since you see it too?
(Reporter)

Comment 4

10 years ago
Request this be marked as a regression.

Comment 5

10 years ago
BenoitRen to the rescue!

->confirmed
->keyword: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Hello Ed,

I think this is no more a valid bug? because the UI changed totaly in the last 6 years...
can you confirm from your site?

thank you for a short update
Flags: needinfo?(ehume)
(Reporter)

Comment 7

4 years ago
This is no longer a valid bug. The UI change has fixed it.
Flags: needinfo?(ehume)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.