Fake scrollbars fail to scroll window when scrollbars clicked while app is in background

RESOLVED FIXED in mozilla2.0b2

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: mstange)

Tracking

({regression})

Trunk
mozilla2.0b2
PowerPC
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Native scrollbars in Mac apps respond to clicks when the app is in the background by 1) bringing the app to the foreground and 2) scrolling to the appropriate place.  Scrollbars are the only widgets that should do this (all other widgets, unless invoked with cmd, simply bring the app to the front when clicked), and our native scrollbars used to this properly.  Our fake scrollbars do not.

STR:

1) Open a trunk Gecko app with a window that has a scrollbar
2) Put the app in the background, but where the scrollbar is still visible
3) Click in the scroll well or on one of the scroll arrows

ER: Gecko app comes to front and scrolls the requested amount
AR: Gecko app comes to front, does not scroll at all

(This sounds a bit familiar, but I can't find a dupe, so apologies if it is one....)

Updated

9 years ago
Assignee: joshmoz → nobody
(Assignee)

Updated

8 years ago
Depends on: 392188
(Assignee)

Comment 1

8 years ago
Fixed by part 6 in bug 392188:
http://hg.mozilla.org/mozilla-central/rev/f1cd1c78ebd3
Assignee: nobody → mstange
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b2
You need to log in before you can comment on or make changes to this bug.