Adding a lot of panels to Sidebar and clicking on tabs causes a crash

VERIFIED DUPLICATE of bug 37428

Status

P3
major
VERIFIED DUPLICATE of bug 37428
19 years ago
14 years ago

People

(Reporter: shrir, Assigned: slamm)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build used: (2000052310)
Since there is no limit to the panels that can be added to the sidebar,I tried 
the following.

Added around 25 panels (totally) to the sidebar so that the whole of the Sidebar 
window is occupied. 
Now, clicking on any tab near the center or the bottom half of the Sidebar 
causes a crash. 'Loading' message appears for a short while and the browser 
crashes.

Stack Trace:

 Trigger Type:  Program Crash 

 Trigger Reason:  Access violation 

 Thread ID:   

 Call Stack:    (Signature = nsDocShell::GetCurScrollPos cd619040) 
     
   nsDocShell::GetCurScrollPos 
                                              
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 1688]
     
   nsDocShell::SetCurScrollPos 
                                              
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 1715]
     
   nsDocShell::ScrollIfAnchor 
                                              
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2786]
     
   nsDocShell::InternalLoad 
                                              
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 2306]
     
   nsDocShell::Reload 
                                              
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 1090]
     
   nsWebShell::ReloadDocument 
                                              
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 873]
     
   nsObserverBase::NotifyWebShell 
                                              
[d:\builds\seamonkey\mozilla\intl\chardet\src\nsObserverBase.cpp, line 72]
     
   nsMetaCharsetObserver::Notify 
                                              
[d:\builds\seamonkey\mozilla\intl\chardet\src\nsMetaCharsetObserver.cpp, line 
295]
     
   nsMetaCharsetObserver::Notify 
                                              
[d:\builds\seamonkey\mozilla\intl\chardet\src\nsMetaCharsetObserver.cpp, line 
192]
     
   nsObserverNotifier::operator() 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsDTDUtils.h, line 445]
     
   nsDeque::FirstThat 
                                              
[d:\builds\seamonkey\mozilla\xpcom\ds\nsDeque.cpp, line 365]
     
   nsObserverTopic::Notify 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsDTDUtils.cpp, line 1121]
     
   CObserverService::Notify 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsDTDUtils.cpp, line 1270]
     
   CNavDTD::WillHandleStartTag 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1125]
     
   CNavDTD::HandleStartToken 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1388]
     
   CNavDTD::HandleToken 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 724]
     
   CNavDTD::BuildModel 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 472]
     
   nsParser::BuildModel 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1573]
     
   nsParser::ResumeParse 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1452]
     
   nsParser::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1903]
     
   nsDocumentOpenInfo::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 191]
     
   nsUnknownDecoder::FireListenerNotifications
                                              
[d:\builds\seamonkey\mozilla\netwerk\streamconv\converters\nsUnknownDecoder.cpp, 
line 336]
     
   nsUnknownDecoder::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\netwerk\streamconv\converters\nsUnknownDecoder.cpp, 
line 161]
     
   nsDocumentOpenInfo::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 191]
     
   nsHTTPFinalListener::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 1221]
     
   InterceptStreamListener::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCachedNetData.cpp, line 1165]
     
   nsHTTPServerListener::OnDataAvailable 
                                              
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cp
p, line 543]
     
   nsOnDataAvailableEvent::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
412]
     
   nsStreamListenerEvent::HandlePLEvent 
                                              
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106]
     
   PL_HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 576]
     
   PL_ProcessPendingEvents 
                                              
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 539]
     
   _md_EventReceiverProc 
                                              
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1032]
     
   USER32.dll + 0x1820 (0x77e71820)

Comment 1

19 years ago
Adding crash keyword
Keywords: crash
(Assignee)

Comment 2

19 years ago

*** This bug has been marked as a duplicate of 37428 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
verified dup

Comment 4

18 years ago
Hmm, looks like verifier forgot to mark this verified. I'll fix that...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.