"Search in Bookmarks" in the Places Organizer is broken.

VERIFIED FIXED in Firefox 3 beta2

Status

()

P1
normal
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: bugmozz, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3 beta2
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007111920 Minefield/3.0b2pre ID:2007111920

regression from bug 387746
Pal-moz, I can reproduce in the organizer, but wfm in the sidebar. Is this also the case for you? I'm changing summary to reflect this.
Summary: "Search in Bookmarks" is broken. → "Search in Bookmarks" in the Places Organizer is broken.
(Reporter)

Comment 2

11 years ago
nothing in the sidebar.
so I don't know I can search in the sidebar.
(Reporter)

Comment 3

11 years ago
create new profile and restore bookmarks.
sidebar is back.
and I can search in the sidebar.

sorry.
migration should work. you should not have to create a new profile. do not be sorry.
Flags: blocking-firefox3?
OS: Windows XP → All
Hardware: PC → All
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P1
Assignee: nobody → mano

Comment 5

11 years ago
Search results don't display, but a saved query seems to work.
Created attachment 289578 [details] [diff] [review]
patch

Ba-bye buggy OptionsFilter, we'll implement a working persisting method later.
Attachment #289578 - Flags: review?(dietrich)
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 3 M10
Comment on attachment 289578 [details] [diff] [review]
patch

>Index: browser/components/places/content/places.js
>===================================================================
>RCS file: /cvsroot/mozilla/browser/components/places/content/places.js,v
>retrieving revision 1.112
>diff -u -p -8 -r1.112 places.js
>--- browser/components/places/content/places.js	20 Nov 2007 02:01:54 -0000	1.112
>+++ browser/components/places/content/places.js	21 Nov 2007 00:24:57 -0000

>@@ -174,23 +173,19 @@ var PlacesOrganizer = {
>    * any special action, since they're related to selection.
>    * @param   aEvent
>    *          The mouse event.
>    */
>   onTreeClick: function PO_onTreeClick(aEvent) {
>     var currentView = aEvent.currentTarget;
>     var controller = currentView.controller;
> 
>-    // If the user clicked on a tree column header, update the sorting
>-    // preferences to reflect their choices.
>-    // XXXmano: should be done in tree.xml
>-    if (aEvent.target.localName == "treecol") {
>-      OptionsFilter.update(this._content.getResult());
>+    if (aEvent.target.localName != "treechildren")
>       return;
>-    }
>+    

nit: whitespace

looks fine otherwise, r=me.
Attachment #289578 - Flags: review?(dietrich) → review+
mozilla/browser/components/places/jar.mn 1.39
mozilla/browser/components/places/content/bookmarksPanel.js 1.6
mozilla/browser/components/places/content/places.js 1.113
mozilla/browser/components/places/content/placesOverlay.xul 1.21
mozilla/browser/components/places/content/tree.xml 1.87
mozilla/browser/components/places/content/treeHelpers.js delete
mozilla/browser/themes/pinstripe/browser/places/places.css 1.19
mozilla/browser/themes/winstripe/browser/places/places.css 1.21
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

11 years ago
confirmed. fixed. thanks.
verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b2pre) Gecko/2007112604 Minefield/3.0b2pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.