Error pages redirected to from J2EE web.xml don't render as HTML but show as text/plain

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: damianharvey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

I am testing my web application with Firefox 3 BETA. When something bad happens in the application it redirects to a standard error page. This renders as HTML fine in Safari, IE and Firefox 2. In Firefox 3 it displays as plain unrendered text.

The error page is called by the J2EE web.xml deployment descriptor (very standard feature see : http://en.wikipedia.org/wiki/Web.xml)

Good luck and thanks! Loving the new FF look on the Mac. Shiney!

Cheers,

Damian.

Reproducible: Always

Steps to Reproduce:
1. In a J2EE (JEE) Application cause an application error
2. The application will attempt to render the error page
3. FF3 displays the unrendered HTML
Actual Results:  
FF3 displays unrendered HTML

Expected Results:  
FF3 should render the HTML and display as normal page

I wouldn't normally say that this is a major but I suspect it's caused by a background reRender problem so maybe symptomatic of something deeper?
(Reporter)

Comment 1

12 years ago
I created a test case and this problem isn't happening again. The proper *rendered* error page is being displayed. Not sure what the cause is. Please close this issue. I'll reopen if I can get to reoccur.

Thanks,

Damian.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
Sorry. I thought of another test and sure enough it failed. 

I'm using a J2EE framework called Ajax4JSF and if the error is caused during an ajax submit then the page doesn't render properly. I've retested this in Safari and FF2 and confirmed it. I'll take it up with the framework developers.

Thanks.

Damian.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

12 years ago
Severity: major → normal
Damian, should this bug be resolved, then?
(Reporter)

Comment 4

10 years ago
Not by Mozilla.

It's an issue for JBoss.

Thanks.
Thanks for updating this!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.