Sidebar close button drawn incorrect

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
3 months ago

People

(Reporter: micmon, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8) Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112004 Minefield/3.0b2pre

Open FF3 and open the bookmark sidebar. press the close button, but drag the mouse down to the bookmarks so that the sidebar stays open (release mouse). Now, click either into the white area of the bookmarks or move directly back up and hover over the close button. It turns to "pressed" now instead of the normal hover state!

Also, the button seems to draw two focus rings, which is ugly (it should draw no focus ring at all).

Reproducible: Always
(Reporter)

Comment 1

10 years ago
Created attachment 289539 [details]
Screenshot

This shows the states of the close button... the correct hover, the incorrect hover and a pressed state (this actually has another focus ring inside but for what ever reason I cannot screenshot it).

Comment 2

10 years ago
Confirming on a current Linux nightly build. This probably needs to be reassigned, but I'm not sure where it belongs (Toolkit/XUL Widgets?).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

10 years ago
This also affects the back and forward buttons in the find bar.
(Reporter)

Comment 4

10 years ago
The button is also not square... and the icon gets stretched and deformed on it.
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> The button is also not square... and the icon gets stretched and deformed on
> it.

This has been fixed. 

The rest of the bug, though, has not been fixed. Also affected is the "hilight all" button on the find bar btw.

Comment 6

10 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > The button is also not square... and the icon gets stretched and deformed on
> > it.
> 
> This has been fixed. 
> 
> The rest of the bug, though, has not been fixed. Also affected is the "hilight
> all" button on the find bar btw.
> 

The extra focus rings is currently handled in bug 410789.

Updated

10 years ago
Depends on: 410789

Comment 7

10 years ago
Mark as RESOLVED:FIXED.

Comment 8

10 years ago
(In reply to comment #7)
> Mark as RESOLVED:FIXED.

No, the main issue of this bug (see comment #0) is not fixed yet.

Comment 9

10 years ago
[[ It turns to "pressed" now instead of the
normal hover state! ]]

It's native GTK behavior!
I did the same in GNOME-Main-Menu applet, in `gnome-session-save --kill` dialog and in more and more native GTK places.

Bug is invalid.
Press Escape. "Strange" behaviour will move away...

Comment 11

10 years ago
(In reply to comment #9)
> It's native GTK behavior!

No, and I definitely don't see this in any other GTK application.

This is basically the same issue as was reported for the bookmarks toolbar in bug 225434, just in a different place in the UI. The drop down menus for the back and forward buttons and the new, native location bar drop down button all show the same problem as well, by the way.
(Reporter)

Comment 12

10 years ago
Jakub, Elmar is right. In fact this remaining bug is harder to see now, in normal usage it's not very visible. Can probably be marked as a duplicate to bug 225434 as this one is more specific.

Updated

10 years ago
Duplicate of this bug: 419284

Updated

10 years ago
Duplicate of this bug: 405798
The icon in current Trunk is cropped.
(Reporter)

Comment 16

10 years ago
(In reply to comment #15)
> The icon in current Trunk is cropped.
> 

What icon theme?
Tango Generator-generated. Close icon is inherited at all sizes from gnome-icon-theme from SVN and from hicolor.
(Reporter)

Comment 18

10 years ago
Hmm... what gtk theme? Can you attach a screenshot?
Clearlooks, Glossy (Clearlooks engine from SVN), Nodoka, Rezlooks-Charamel...

"It doesn't matter", as Petra Marklund (September) sings (; .
Created attachment 305361 [details]
screenshot from Livio

Updated

8 years ago
Duplicate of this bug: 419208

Updated

8 years ago
Component: Shell Integration → General
Depends on: 225434
QA Contact: shell.integration → general
Version: unspecified → Trunk
(Reporter)

Comment 22

3 months ago
No longer relevant with Photon theme.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.