All users were logged out of Bugzilla on October 13th, 2018

[mlk] Rampant Leaking on Idle/Refresh

RESOLVED DUPLICATE of bug 404645

Status

()

RESOLVED DUPLICATE of bug 404645
11 years ago
11 years ago

People

(Reporter: folletto.id, Unassigned)

Tracking

({memory-leak})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/523.12 (KHTML, like Gecko) Version/3.0.4 Safari/523.12
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O 10.4; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

Mac OSX 10.4.11, Firefox 3.0b1, brand new clean profile.

I was trying to track down a render bug while I noticed that my system was slowing down. Looking at the Activity Monitor I noticed that Firefox was using 800Mb+ of RAM, raising fast.
Forced down.

Reopened it, reloaded the HTML file but after a few refreshes it started again and I've seen going it up by 10-20mb each second.

I didn't have any tool to track it down, so I've fired "Sample" from Activity Monitor, recording 3 samples.
I even tried to make Fx crash in order to get a report, but nothing.

I know that this isn't much useful, but I lost the last 2 hours trying to reproduce this reliably, but nothing. Feel free to close it if the samples aren't enough to do anything.

I'm using Portable Firefox CX for OSX to launch a clean profile. I don't know it this could be useful, but I'm trying to cover everything.



Reproducible: Sometimes

Steps to Reproduce:
I can't reproduce it reliably. :(



Actual Results:  
Skyrocketing RAM usage. Up 10-20mb each second.




Expected Results:  
Stable RAM usage at idle. :P
(Reporter)

Comment 1

11 years ago
Created attachment 289579 [details]
Sample of Firefox On Memchomping 1
(Reporter)

Comment 2

11 years ago
Created attachment 289581 [details]
Sample of Firefox On Memchomping 2

Same session, still raising...
(Reporter)

Comment 3

11 years ago
Created attachment 289582 [details]
Sample of Firefox On Memchomping 3

...still raising. Last sample taken.

Comment 4

11 years ago
That was on this site: http://im.digitalhymn.com/ I think ?
I noticed that madness as well, when viewing it with Fx b1 to analyse bug 404660.
Minefield latest nightly and my Camino trunk build didn't have any problem.
(Reporter)

Comment 5

11 years ago
Hi Philippe. :P
Yes, that was what I was working on when I noticed this issue.
I'm glad that it's fixed in some ways on the latest nightly. :)

Comment 6

11 years ago
I don't know for sure if it is fixed or not. The latest nightly I have (20071120) is stable on that site (both with the same profile as I used for FX b1, and with my usual profile for nighty builds).

Note similar issues in bug 403481.
Keywords: mlk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404645
You need to log in before you can comment on or make changes to this bug.