ASPX Pages: Uncommented code treated as comments

RESOLVED DUPLICATE of bug 214476

Status

()

Core
General
--
major
RESOLVED DUPLICATE of bug 214476
11 years ago
11 years ago

People

(Reporter: Josh, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Can't post site as it's an Intranet page for the company I work for, however I have been able to 100% narrow down what causes this to happen. This bug only appears to affect ASPX pages (Microsoft .NET), not HTML pages.

When a comment contains additional dashes, the rendering engine misses the end of the comment. For example:

<--

This is my page header
This next line causes problems when present
-------------------------------------------
Everything else here works fine if I remove the line above.
-->

This would be HTML rendered in MSIE (and should be rendered), but is not rendered when the dashed line above is present.

<-- This is another comment, which may or may not have more dashes in it. -->

When I create an ASPX page on my desktop and try to open it with firefox (not being served through IIS, just a file:// URI), I get the following error:

XML Parsing Error: not well-formed
Location: file:///C:/Documents%20and%20Settings/Josh/Desktop/test.aspx

However, when I serve the above page through an IIS webserver, the above stated behavior occurs.

Reproducible: Always

Steps to Reproduce:
1. Create ASPX page with multiple comments.
2. Add a line of dashes ("-") to the comment. Such as would be used to format multiline comments for page banners.
3. Load up in Firefox.
Actual Results:  
HTML after the comment with the dashes, and prior to the next comment, was ignored by the rendering engine.

Expected Results:  
Rendered the valid HTML between the comments.

Only seems to happen with ASPX pages. If the extension is changed to HTML or HTM, the page renders fine (with the obvious side effect of server code showing up on the client side).

Tagged as major as this definitively breaks websites that utilize this comment format.

Comment 1

11 years ago
Firefox doesn't speak ASPX.  (nor does any other browser for that matter afaik)
Firefox speaks xhtml, html, css, svg, xul, etc.

* Find a page with this problem that works in other browsers **served by a web server** not a local file accessed directly.
* Save page using file -> save as "web page html only"
* attach page here
Component: File Handling → General
Product: Firefox → Core
QA Contact: file.handling → general
Whiteboard: CLOSEME 12/20
Version: unspecified → 1.8 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: CLOSEME 12/20
Duplicate of bug: 214476
You need to log in before you can comment on or make changes to this bug.