Closed Bug 404780 Opened 12 years ago Closed 7 years ago

Using RFC 2397 "data" URLs in an embed element does not work for sound files.

Categories

(Core :: Plug-ins, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: drj, Unassigned)

References

()

Details

(Whiteboard: parity-webkit)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

URL has a single EMBED element that contains directly in the src attribute a .wav file encoded as an RFC 2397 URL.  Warning for those viewing source: it contains a line > 50KB.

This object does not display and play properly in Firefox.  I get an embedded quicktime window but it is all greyed out and a big white question mark is drawn on top.

Replacing the "data" URL in the embed element with an image, data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGAAAABgAQMAAADYVuV7AAAABlBMVEUAAAD///+l2Z/dAAAAIUlEQVQ4jWP4DwMMQDDKIZHDAAGjnFEO7TkMcDDKIZYDAAVlPd9Ahj+EAAAAAElFTkSuQmCC , for example, works just fine.

The URL works in Safari.

Support for this would be very useful (for me) because it enables the creation of sound files programmatically in JavaScript; those sound files can then be played by creating a suitable embed element.

Reproducible: Always

Steps to Reproduce:
Go to URL.
Actual Results:  
Embedded Quicktime controller is all greyed out.

Expected Results:  
A working embedded Quicktime controller.



The sound file, by the way, is approximately 640 milliseconds of 400Hz sine wave.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
I should point out that I use this technique (or try to) to implement the "beep" command in Curly Logo:

http://www.amberfrog.com/logo/

Sound works in Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.8.1.10) Gecko/2007112611 Ubuntu/7.10 (gutsy) Firefox/2.0.0.10
Whiteboard: parity-safari
Whiteboard: parity-safari → parity-webkit
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.