Line breaking- Hankaku Katakana kinsoku does not work

VERIFIED FIXED in M4

Status

()

Core
Internationalization
P2
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Tested 3-19-99 Win32 build.

In the above page, #1, #7, and #12 contains hankaku katakana.

Step of reproduce
1. Move mouse to wrap the line.
2. look at the hankaku kakataka, especially "ジ" "ゲ' and "パ"

These characters wrapped in the middle of the characters,
for example "ジ" characters is wrapped  "シ" and "゙".
This is one character, and it should be wrapped in the middle of the character.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M4
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
Is this dup of 3883 ?
(Assignee)

Comment 2

19 years ago
Is this dup of 3883 ?
(Reporter)

Comment 3

19 years ago
This is not dup of #3883.  #3883 is the small hankaku and hiragana problem.
(Assignee)

Updated

19 years ago
Summary: Hankaku Katakana kinsoku does not work → Line breaking- Hankaku Katakana kinsoku does not work
(Assignee)

Comment 4

19 years ago
The problem is U+ff61-U+ff9f are not part of the JIS 4501 spec and I just map
them to some class. The U+FF9E (KATAKANA VOICED SOUND MARK) and U+FF9F (KATAKANA
SEMI-VOICED SOUND MARK) does not map to a reasonably class. We should map them
to the Class 3 of JIS 4501 and treat them as other Prohibited Line Beginning
Kana, such as A, I ... etc.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
Fix and check in March 22,1999 5:12 PM. Please verify build after this check in
time. Thanks.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Verified as fixed in 3-23 Win32 build.
You need to log in before you can comment on or make changes to this bug.