Filter/Search UI: implement tabbing to/from fields

VERIFIED WORKSFORME

Status

MailNews Core
Filters
P3
major
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: Håkan Waara)

Tracking

({access})

Trunk
Future
access

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using may24 m16 commercial build


Using Tab or Shift+Tab will not move to/from fields within the current Message
Filter UI.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel
(Reporter)

Comment 1

18 years ago
This should include both the main Message Filters dialog and the Filter Rules
subdialog.  It should also include buttons, widgets, text fields, etc.

Comment 2

18 years ago
ugh, this should just be working, if it's not then something might be broken 
with XBL.
Status: NEW → ASSIGNED
Target Milestone: --- → M18

Comment 3

18 years ago
moving to future milestone.
Target Milestone: M18 → Future

Comment 4

17 years ago
reassigning my filter bugs to gayatrib..
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW
(Reporter)

Updated

17 years ago
Summary: Filter UI: implement tabbing to/from fields → Filter/Search UI: implement tabbing to/from fields
(Reporter)

Comment 5

17 years ago
*** Bug 68893 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Severity: normal → major
Keywords: access

Comment 6

17 years ago
reassigning to naving
Assignee: gayatrib → naving
(Assignee)

Comment 7

17 years ago
Taking for now. Don't know when/if I will fix it.
Assignee: naving → hwaara
(Assignee)

Comment 8

17 years ago
Yay. Works like a charm in both the Search window and FilterEditor/FilterList.

Resolving as worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

16 years ago
Tabbing implemented in Search Messages, Message Filters and Filter Rules dialogs.
There are a couple issues with initial focus in the window (Mac & Linux) and
with a couple fields.  Will log those as separate accessibility bugs.
OK using aug10 commercial trunk build: win98,mac OS 9.0 and linux rh6.2
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.