Filter UI: Enter from criteria line closes dialog, need to implement spec behavior.

VERIFIED DUPLICATE of bug 49474

Status

P3
normal
VERIFIED DUPLICATE of bug 49474
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: gayatrib)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Using may24 m16 commercial build

Mail filter ui spec: http://gooey/client/5.0/specs/mail/filters/Filters.html

Using the current build, when you're in a filter rules dialog criteria line
value/text field and you press Enter, the dialog closes; it should not. There is
a description of the behavior for the criteria lines when leaving a line via
Tab, click or Enter, so that the criteria line area behaves similar to the
message compose window's addressing widgets/lines.

Please implepment:
1.  Per spec:  When focus leaves the last criteria row (using Enter, clicking
out of row, tabbing out, etc.) and the row is not empty, a new filter criteria
row with widgets is created.
2.  I assume:  When using Enter, we should follow Addressing example. I would
think that should mean if the last row is empty we need to move to the next
field, which should be the Action widget.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 1

19 years ago
yep, I'll do this as a part of removing More/Less
Status: NEW → ASSIGNED
Depends on: 40491
Target Milestone: --- → M18

Comment 2

19 years ago
moving to future milestone.
Target Milestone: M18 → Future

Comment 3

18 years ago
reassigning my filter bugs to gayatrib..
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW
(Reporter)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 49474 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.