Handling of Type1 fonts broken - displays as garbage

RESOLVED DUPLICATE of bug 396315

Status

()

--
major
RESOLVED DUPLICATE of bug 396315
11 years ago
11 years ago

People

(Reporter: paul.lebeau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

It appears as if the handling of all Type1 fonts is completely broken.
Discovered because I tried changing my default sans-serif font to "Helvetica 55 Roman" which, on my machine, is a Type1 font.  Pages that use the default sans-serif font then display as garbage.  More specifically the wrong glyphs are being displayed.

I tested all the Type1 fonts on my system with the same result.

I will attach screenshots to show the problem.

Reproducible: Always

Steps to Reproduce:
1. In the options window, change default sans-serif font to a Type1 font
2. Browse to Wikipedia
3. Scratch head
Actual Results:  
All fonts using default sans-serif style on the page will appear scrambled with random glyphs
(Reporter)

Comment 1

11 years ago
Created attachment 289809 [details]
Wikipedia main page with default sans-serif font set to Arial (Truetype)

What wikipedia looks like with the default sans-serif font set to the default of Arial.
(Reporter)

Comment 2

11 years ago
Created attachment 289810 [details]
Wikipedia main page with default sans-serif font set to Helvetica 55 Roman (Type1)

Chane default sans-serif font to a Type1 font and you get something that looks like this.
(Reporter)

Comment 3

11 years ago
Bug 366983 is probably the same bug, or at least related, but is worded more specifically and doesn't describe the general case of all Type1 fonts being broken.

Comment 4

11 years ago
Duplicate of bug 396315 ??
Flags: blocking-firefox3?

Updated

11 years ago
Component: General → General
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 5

11 years ago
Looks like it.  Thanks for finding that Tom.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396315
You need to log in before you can comment on or make changes to this bug.