Quick search accelerator is keyboard layout-dependent

RESOLVED INVALID

Status

()

Core
Keyboard: Navigation
--
minor
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: sikon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112313 Firefox/3.0b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112313 Firefox/3.0b2pre

Bug #69230 was only partially fixed. The fix still does not apply to the quick search key ('/').

Reproducible: Always

Steps to Reproduce:
1. Switch to a foreign keyboard layout.
2. Press /.
3. Switch to the English keyboard layout.
4. Press / again.
Actual Results:  
The quick search panel is only activated the second time.

Expected Results:  
The quick search panel is activated both times.

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → Keyboard: Navigation
Ever confirmed: true
Product: Firefox → Core
CC'ing author of patch for Bug 69230
Oleg, can you please explain, is it intended behaviour?

Comment 2

11 years ago
(In reply to comment #1)
> CC'ing author of patch for Bug 69230
> Oleg, can you please explain, is it intended behaviour?
> 

Yes, this is intended behavior, as explained in original bug we don't handle punctuation as each layout has it (but in different places).

Original test case doesn't specify the exact 'foreign layout'. For example greek layout has slash in the same location as US layout so it will work as intended. In case of for example Russian layout there is a slash key in different place and you need to press it to activate the quick search.

The Bug #69230 was for keys which are absent in current layout (that way we need to try to use other possible symbol from other layout): for example in Russian layout there is no latin letter 'T' for Ctrl+T shortcut and we must try all possible other layouts searching for latin T. In case of punctuation it's different: each layout has punctuation (it may be on different key though), so I think it's not a bug.

QA Contact: keyboard.navigation → keyboard.navigation
Marking bug as INVALID per comment #2
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.