redundant confirmation in addon update

RESOLVED DUPLICATE of bug 397493

Status

()

Toolkit
Add-ons Manager
--
enhancement
RESOLVED DUPLICATE of bug 397493
10 years ago
9 years ago

People

(Reporter: Stanislav Malyshev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

When I launch the browser and one of the addons can be updated, Firefox prompts me to install the update. After the installation is finished, I am presented with "continue" button which I must click in order to proceed with launching the browser. I think this "continue" button is redundant and should be removed, as soon as the updates are installed the browser should immediately proceed with launching. 
This confirmation is both unnecessary - since I have no option other than to continue - and unproductive, since download may take some time, I might switch to another window in hope that once it's done the browser would launch and then I'll know it's ready for me. Instead, it just waits me to continue and forces me to check on it, and then when I click continue I must wait again for the loading itself to finish. It reduces usability and irritates the user.
Of course, if any of the installations failed, then it might be OK to have the user informed about it. But only if something fails - if installations are OK, it should silently proceed.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox while some addon is not latest version
2. See Firefox prompring update
3. Install update
4. See "continue" button

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397493
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.