If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Email Compose window does not close itself after Account Wizard Cancel/Exit.

RESOLVED FIXED in seamonkey2.0

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0, regression})

Trunk
seamonkey2.0
x86
Windows 2000
fixed-seamonkey2.0, regression
Bug Flags:
blocking-seamonkey2.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Confirming bug 201941 comment 4.

0. Use a profile without an email account.
1. Click a <mailto:> link.
2. Cancel + Exit Account Wizard.
2r. Email Compose window remains opens. (instead of closing itself.)

This regressed between
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007092702 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)
and
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a9pre) Gecko/2007092802 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

From
<http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-27+02&maxdate=2007-09-28+03&cvsroot=%2Fcvsroot>
I would try and guess bug 391777 ?
(Assignee)

Comment 1

10 years ago
Created attachment 290135 [details] [diff] [review]
Gross hack
[Checkin: See comment 6]

Modal windows can no longer close their parents so this works around it.
Attachment #290135 - Flags: superreview?(mscott)
Attachment #290135 - Flags: review?(mnyromyr)
(Assignee)

Comment 2

10 years ago
OK, so the reason we need the hack is this:

During compose window load, we verify that there is an account. If there is no account, then the new account wizard is launched via a timeout so that compose startup can continue later. If you cancel the account wizard then you want to close the compose window but you can't do that while the account wizard is open because of new checks to prevent windows with modal dialogs from being closed.

Updated

10 years ago
Attachment #290135 - Flags: superreview?(mscott) → superreview+

Updated

10 years ago
Attachment #290135 - Flags: review?(mnyromyr) → review+

Comment 3

8 years ago
This bug is open but targeted for seamonkey2.0a1, which has been released a long time ago. Please set the target milestone to an appropriate value, "---" if it has no specific target.
(Reporter)

Comment 4

8 years ago
Neil, patch needs landing, in c-c now...
Assignee: mail → neil
Status: NEW → ASSIGNED
Flags: blocking-seamonkey2?
QA Contact: mailnews-account
Whiteboard: [patchlove]
Target Milestone: seamonkey2.0a1 → ---

Updated

8 years ago
Flags: blocking-seamonkey2.0? → blocking-seamonkey2.0+
Attachment #290135 - Flags: approval-seamonkey2.0+
Comment on attachment 290135 [details] [diff] [review]
Gross hack
[Checkin: See comment 6]

a=Standard8 for landing this (with any bitrot fixed).
(Reporter)

Comment 6

8 years ago
Comment on attachment 290135 [details] [diff] [review]
Gross hack
[Checkin: See comment 6]


http://hg.mozilla.org/comm-central/rev/6dbd4ce05e2e
Attachment #290135 - Attachment description: Gross hack → Gross hack [Checkin: See comment 6]
(Reporter)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED
Whiteboard: [patchlove]
Target Milestone: --- → seamonkey2.0
You need to log in before you can comment on or make changes to this bug.