Closed Bug 405238 Opened 15 years ago Closed 14 years ago

Middle-clicking a link focuses the newly opened tab (even though option is disabled)

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 405239

People

(Reporter: breght, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

Seen a few times with 3.0b1: clicking the middle mouse button opens a new tab and immediately focuses that tab (even though the setting is disabled in the options-menu). So far, it is hard to reproduce. First saw this problem while navigating http://www.ubuntuhomeserver.org/

Reproducible: Sometimes

Steps to Reproduce:
1. Open a site
2. Middle click on a link
3. Wait for the magic to happen
Actual Results:  
A new tab is opened with the contents of the referred page. Incidentally, this newly opened tab is directly focused (i.e. the active tab changes).

Expected Results:  
A new tab opens at the end of the list, but does not receive focus if this option has not been specifically set by the user
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110703 Firefox/3.0b1

Could not reproduce. Middle clicking every link on the mentioned page opened a new tab without focussing.
Try to set the option for confirming cookies. This will produce the reported behavior. Possibly related to Bug #405239
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
You need to log in before you can comment on or make changes to this bug.