Not possible to set "Connection: close" header using setRequestHeader XMLHttpRequest method

RESOLVED WONTFIX

Status

()

Core
DOM
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: Rafał, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [wontfix?], URL)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.50 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112005 Minefield/3.0b2pre

Using XMLHttpRequest setRequestHeader method to set Connection: close header does not work in Firefox 3 beta build

Reproducible: Always

Steps to Reproduce:
1. Create XHR request
2. Use setRequestHeader method to specify "Connection: close" header
3. Send request and see what headers are sent (server side way or by sniffing)
Actual Results:  
Sends general Connection: keep-alive header

Expected Results:  
Should send Connection: close we specified

Works as expected in firefox 2.

Comment 1

11 years ago
I believe this is by design. The change was made in bug 389508, it seems.

http://www.w3.org/TR/XMLHttpRequest/#setrequestheader

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/content/base/src/nsXMLHttpRequest.cpp&rev=1.212#2172
Blocks: 389508
Component: General → DOM
Keywords: regression, testcase
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk

Comment 2

11 years ago
By the way, thanks for a nice testcase!
Whiteboard: [wontfix?]
(Reporter)

Comment 3

11 years ago
OK, thanks for clarification.
Closing this as it seems to be by design. This has no relation to bug 389508 though.
No longer blocks: 389508
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.