Freeze when spell checking some long words using french dictionnary

RESOLVED FIXED

Status

()

Core
Spelling checker
--
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Mathieu Deletrain, Unassigned)

Tracking

({hang})

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
Build Identifier: version 2.0.0.9 (20071031)

The spell check algorithm seems to have troubles checking certain long words, especially with the french dictionnary (also works with the english one, but it is less visible)

For example, it has no problem checking 'kjdbbfgjkbgjkqbfkgbfgqfdgjkqfdjkghfhgjkqfdhgjkqdfhgjkqhd', but it's slow as hell when checking 'readMessageFromHttpRequestFoobarFoobarFoobar'.

Also, it only as trouble when opening the spell-check window, since the word is correctly underlined while typing the message, without any particular slow-down.

Reproducible: Always

Steps to Reproduce:
1.If not installed, install the french dictionnary
2.Create a new mail
3.fill a destination email
4.fill a subject
5.write the line readMessageFromHttpRequestFoobarFoobarFoobar
6.copy-past this line several times (someting like 10 times should be enough)
6.Click on the spell-check button
Actual Results:  
The application seems to be frozen, but if you let it work for say, several hours, it will finally be able to open the spell-check window.


Expected Results:  
The spell-check window should appear immediatly (or at least after a very short delay)

Tested on Pentium 4 3Ghz with 1Go of Ram, Windows XP SP2

Comment 1

9 years ago
It's the same with the German dictionary. Could it be that it's not about the specific dictionary being somehow bad, but that the cause is the structure of the language (building long composite words written together).

Comment 2

9 years ago
And (sorry for bug spam): This is the same with Firefox, edit a Wikipedia article with very long words and then try the steps above.
Component: Message Compose Window → Spelling checker
Product: Thunderbird → Core
QA Contact: message-compose → spelling-checker

Comment 3

9 years ago
I don't see any trace of this with EN-US dictionary using thunderbird 2 or 3.  (but tested on a fast system)

do you see this using version 3 beta? 
 (backup your profile first)
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Severity: normal → critical
Keywords: hang
Version: unspecified → 1.8 Branch
(Reporter)

Comment 4

9 years ago
I just tried the above steps on a Core 2 quad core Q9450 (powerful enough I hope) on Thunderbird 2.0.0.21

It works fine using EN_US dictionnary, but still does not work using the french one.

I also tried using Thunderbird 3 beta2 on an AMD 64 X2 dual core 5000+ and it seems a lot better, even if a small hang could be noticed.

Still need to test both versions on the same PC ... as soon as I can.

Comment 5

9 years ago
I don't observe this problem with the French dictionary version 2.0, Firefox 3.5, although think I can observe a very slight difference in the speed of checking those two nonwords. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)

Looks like this bug was fixed by the switch to Hunspell spelling checker (in Firefox 3.0, Thunderbird 3.0), and the original reporter's comment 4 also confirms this. Resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.