Browser crashes when trying to display large (wide?) PNG [@ rgba32_image_ARGB32] [@ argb32_sample_ARGB32]

RESOLVED WONTFIX

Status

--
critical
RESOLVED WONTFIX
11 years ago
8 years ago

People

(Reporter: bsb, Assigned: jaas)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash
Bug Flags:
wanted1.8.1.x -

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.8pre) Gecko/20071022 Firefox/2.0/1.6a1pre (like Firefox/2.0.0.8pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.9) Gecko/2007102514 Firefox/2.0.0.9

Similarly to a bug seen under Linux (bug 390768), Firefox crashes when trying to display a large PNG file. Several version of Firefox seem to be affected, namely v1.x up to 2.0.0.9. The same problem is not seen under Windows, but it does affect Camino.

Reproducible: Always

Steps to Reproduce:
1. Go to referenced website.
2. Try to scroll right to see more of the large picture.



When run on the command line:

/Applications/Firefox.app/Contents/MacOS/run-mozilla.sh: line 424:  9222
Segmentation fault      "$prog" ${1+"$@"}
(Reporter)

Comment 1

11 years ago
Created attachment 290223 [details]
Stack trace provided by Apple's Crash Reporter
Attachment #290223 - Attachment mime type: application/text → text/plain
Assignee: nobody → joshmoz
Status: UNCONFIRMED → NEW
Component: General → GFX: Mac
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: general → mac
Summary: Browser crashes when trying to display large (wide?) PNG → Browser crashes when trying to display large (wide?) PNG [@ rgba32_image_ARGB32] [@ argb32_sample_ARGB32]
Version: unspecified → 1.8 Branch

Comment 2

11 years ago
I tried http://www.sanger.ac.uk/cgi-bin/software/analysis/logomat-m.cgi?pfamid=PF04735 and couldn't get Firefox to crash.  I'm using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1pre) Gecko/2008071017 Minefield/3.1a1pre

Are you still seeing this bug?  If so, with what version of Firefox and Mac OS X?
(Reporter)

Comment 3

11 years ago
Indeed, Firefox 3.0 on 10.5.4 seems to work fine. The last time I checked I must have used Firefox 2.xyz on Tiger.
Product: Core → Core Graveyard
This isn't worth taking on 1.8 now, so I'm minusing it for 1.8.1.x and marking it as WONTFIX since it's a 1.8-only bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: wanted1.8.1.x-
Resolution: --- → WONTFIX
Crash Signature: [@ rgba32_image_ARGB32] [@ argb32_sample_ARGB32]
You need to log in before you can comment on or make changes to this bug.