Dragging a tab onto its content area reloads that page

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: dean_tessman, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

1. Drag a tab onto its content area

Expected Results: nothing happens
Actual Results: page loads

This was fixed, oh, a year ago, but now is broken again.  My first suspicion is that it's related to the check-in for bug 374593, so assigning to Jim.
This isn't Windows only. I'm on Linux, and dragging a tab onto its content area reloads that page for me as well.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Duplicate of this bug: 409186
Assignee: jmathies → nobody
This issue occurs on all platforms. The correct scenario for reproduction is on a single-tab window. For example:

1. Open a new window and add another tab to it (should have 2 tabs).
2. Drag one of the tabs to either its content area or outside the browser (onto the desktop).
3. Drag that the tab in the new single-tab window anywhere in it's content area.


Actual Results:
After step 2, there will be two windows with a single tab in each.
After step 3, the tab that was dragged will not reload.
After step 4, the tab that was dragged will be reloaded.

Expected Results:
After step 2, that's correct.
After step 3, that's correct.
After step 4, the tab should not reload.
Aakash, the behavior you can see is related to the latest work for tearing-off tabs. This bug was filed nearly 1,5 years ago. I still miss step 4.

But the problem is that the single tab gets teared-off into a new window. Doing that from a window with only one tab open doesn't make much sense. Don't we have a bug which already covers that?
(In reply to comment #5)
> Yes, that's bug 474908.

So half of the work has been fixed by the patch on bug 474908 but the main patch, which fixed this problem, is one of those tear-off patches. Resolving this bug as WFM.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.