[Trunk] Event dialog: Typed start time or end time reset to default after moving focus

VERIFIED FIXED in 1.0b1

Status

Calendar
General
P2
major
VERIFIED FIXED
11 years ago
7 years ago

People

(Reporter: aryx, Assigned: dbo)

Tracking

Bug Flags:
blocking-calendar1.0 +
tb-integration +

Details

Attachments

(1 attachment)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112604 Calendar/0.6a1

New event: Typed start time or end time reset to default after moving focus.

STR: Simply create an event in a new profile.
Whiteboard: dupeme
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080212 Lightning/0.8pre (2008021219) Thunderbird/2.0.0.13pre

Maybe a Trunk only issue?

Comment 2

10 years ago
I am seeing this too with the trunk build.  If you change the time say from 2:00 pm to 3:00 pm and then hit the tab key or click on a different field with the mouse it reverts back to 2:00 pm.  If you press the Enter key it works OK?  However, pressing Enter also accepts the event, so that is not really feasible either.  
Confirmed with Windows and Linux on Trunk only.
Severity: normal → major
Component: Internal Components → General
OS: Windows XP → All
QA Contact: base → general
Hardware: PC → All
Summary: New event: Typed start time or end time reset to default after moving focus → [Trunk] Event dialog: Typed start time or end time reset to default after moving focus
Whiteboard: dupeme
Flags: tb-integration?
Flags: blocking-calendar1.0?
(Assignee)

Updated

10 years ago
Flags: blocking-calendar1.0? → blocking-calendar1.0+

Updated

10 years ago
Flags: tb-integration? → tb-integration+
Can still reproduce with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081015 Calendar/1.0pre
1. Create new event.
2. Type "10/20/2008" into end date.
3. Press tabulator
Priority: -- → P2
(Assignee)

Comment 5

10 years ago
Created attachment 349412 [details] [diff] [review]
fix - v1

Only tested on Mac so far.
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #349412 - Flags: review?(Berend.Cornelius)

Comment 6

10 years ago
(In reply to comment #5)

> Only tested on Mac so far.

Works nicely on Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081121 Sunbird/1.0pre

c-c revision 92340767c728 with the patch applied.

Comment 7

10 years ago
Comment on attachment 349412 [details] [diff] [review]
fix - v1

looks and works well. r=berend
Attachment #349412 - Flags: review?(Berend.Cornelius) → review+
(Assignee)

Comment 8

10 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/821c67240aec>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0

Comment 9

10 years ago
Checked in sunbird and lightning build 20081130 -> VERIFIED.
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.