Closed Bug 405679 Opened 13 years ago Closed 13 years ago

When performing a search on WordPress.org, the search results are not rendered on Vista, effective Sep 29, 2007.

Categories

(Core :: Disability Access APIs, defect, P5)

x86
Windows Vista
defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta2

People

(Reporter: MarcoZ, Assigned: aaronlev)

References

()

Details

(Keywords: access, regression)

Perform the following steps:
1. With accessibility enabled in Minefield, visit http://wordpress.org.
2. In the Search box, type "trackback" (without the quotes), and press ENTER.
3. After the Search Results come up, use AccExplorer32 to explore the Accessibility tree.

Result: Search results come up, but only the Document Node is visible in AccExplorer, it has no children.

More information:
1. I cannot reproduce this on XP, only on Vista.
2. If I force Minefield to restart (e. g. by disabling or enabling a plugin), while the Search Page is still loaded, after the reload, the Search Page comes up fully rendered. It only fails to render to a11y if I come from the Search box on the WordPress's home page.
3. The regression range is:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-09-28+02%3A00&maxdate=2007-09-29+05%3A00&cvsroot=%2Fcvsroot
Flags: blocking1.9?
Hard to say which of those patches could have affected this.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P5
Marco, I am unable to reproduce this. Can you back out the various patches and figure out which caused the regression?
Marco, it's probably bug 397112. Can you check?
Another way to reproduce this for me is to simply go to https://bugzilla.mozilla.org, log in, and click the "My bugs" link. The page comes up empty.

I will back out fix for bug 397112 and see if that fixes me.
Same regression range as bug 408997.
Moving to wanted list...please ren-nom if you disagree this should really block
Flags: wanted1.9+
Flags: blocking1.9-
Flags: blocking1.9+
As documented in bug 408997, that bug and this one both have the root cause in the fix for bug 397112. I am seeing this in far more places than just the WordPress example given, it often hits me in bugzilla as well. Aaron has a handle on the problem, so we should have a fix for beta 3 I think. Re-requesting blocking.
Flags: blocking1.9- → blocking1.9?
Ok - if that's the case we need a much higher priority on this than P5...
Blocks: 397112
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Fixed by the fix for bug 408997.
Status: RESOLVED → VERIFIED
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.