Firefox does not prompt for SOCKS5 username/password

RESOLVED DUPLICATE of bug 122752

Status

()

RESOLVED DUPLICATE of bug 122752
11 years ago
9 years ago

People

(Reporter: seerdecker, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070719 Iceweasel/2.0.0.5 (Debian-2.0.0.5-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20070719 Iceweasel/2.0.0.5 (Debian-2.0.0.5-2)

In the proxy configuration page, you can enter the address and port
of a SOCKS5 proxy server but you cannot provide a username/password pair.

When asked to connect to a website, Firefox does not prompt for the username/password and displays a blank page. It is thus impossible to use a private SOCKS5 proxy that isn't open to all the internet with Firefox.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
Firefox should do as other software do and display two textfields to enter the username / password pair in the configuration page. Alternatively, it could prompt for a username / password pair when connected to the SOCKS5 proxy, although the user, not Firefox, really knows whether a password is necessary.

Comment 1

10 years ago
The same behaviour in: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9.0.6) Gecko/2009020409 Iceweasel/3.0.6 (Debian-3.0.6-1)
This bug was originally reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.6 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 2010-07-30]
Version: unspecified → 2.0 Branch

Comment 4

9 years ago
It is still not working, but it is a dupe of bug 122752.
Then we will mark it a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: [CLOSEME 2010-07-30]
Duplicate of bug: 122752
You need to log in before you can comment on or make changes to this bug.