Closed Bug 406028 Opened 12 years ago Closed 12 years ago

Call callback immediately when install is blocked

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9beta3

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

When an install is blocked we currently retain the callback in case the user hits the new allow button. This can cause issues including the crash in bug 401624. The plan is to just call the callback and tell it that the install was blocked then drop the callback.

This means that the callback function becomes less useful for web developers.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla1.9 M11
Attached patch patch rev 1Splinter Review
This is a fairly simple patch, we just only retain the callback if we are whitelisted and going directly to the install stage. This makes us consistent with the 1.8 branch behaviour ignoring the fact that blocked install attempts can be restarted at a later point without the website knowing.

The field reordering in nsXPIInstallInfo.h just cleans up a compile time warning.
Attachment #292395 - Flags: superreview?(dveditz)
Attachment #292395 - Flags: review?(dveditz)
Status: NEW → ASSIGNED
Whiteboard: [has patch]
Comment on attachment 292395 [details] [diff] [review]
patch rev 1

r/sr=dveditz
Attachment #292395 - Flags: superreview?(dveditz)
Attachment #292395 - Flags: superreview+
Attachment #292395 - Flags: review?(dveditz)
Attachment #292395 - Flags: review+
Attachment #292395 - Flags: approval1.9?
Attachment #292395 - Flags: approval1.9? → approval1.9+
Checking in xpinstall/src/nsJSInstallTriggerGlobal.cpp;
/cvsroot/mozilla/xpinstall/src/nsJSInstallTriggerGlobal.cpp,v  <--  nsJSInstallTriggerGlobal.cpp
new revision: 1.61; previous revision: 1.60
done
Checking in xpinstall/src/nsXPIInstallInfo.h;
/cvsroot/mozilla/xpinstall/src/nsXPIInstallInfo.h,v  <--  nsXPIInstallInfo.h
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [has patch]
Duplicate of this bug: 433686
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.