nsLocalHandlerApp fails to hand off URI correctly for some apps

RESOLVED DUPLICATE of bug 57420

Status

()

RESOLVED DUPLICATE of bug 57420
11 years ago
11 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

11 years ago
Some protocol handling apps require specific command line params indicating the type of action to take. When firefox has a user defined protocol handler (not the system default) these extra parameters are lost. 

WinMail.exe is a good example with the mailto protocol - 

"c:\(path)\winmail.exe mailto:foo@bar.com" 

will launch winmail, but fail to open the compose view. For this to work, it must be of the form -

"%ProgramFiles%\Windows Mail\WinMail.exe" /mailurl:"mailto:foo@bar.com"

nsLocalHandlerApp's LaunchWithURI will need to be updated.
(Assignee)

Updated

11 years ago
Blocks: 393122
(Assignee)

Updated

11 years ago
Flags: blocking-firefox3?
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3?
Resolution: --- → DUPLICATE
Duplicate of bug: 57420
(Assignee)

Updated

11 years ago
No longer depends on: 400852
You need to log in before you can comment on or make changes to this bug.