Print function only prints a portion of the webpage.

RESOLVED DUPLICATE of bug 129941

Status

()

RESOLVED DUPLICATE of bug 129941
11 years ago
9 years ago

People

(Reporter: info, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

Printing webpage results in only 3 pages of 9 printed.  Print preview shows same result.  Same pages printed to PDF (using CutePDF).  Same page in IE prints fine and displays fine in print preview.  Seems like a straight HTML text page, no frames.

Some websites print fine, others don't.  VNC page is only recent example so it's all I can provide right now.

Reproducible: Always

Steps to Reproduce:
1.Go to selected page
2.Select print or print preview
Actual Results:  
Prints 3 pages (one of text, two of headers/images).  Print preview shows exact same pages.

Expected Results:  
Print all 9 pages with text on all pages.

Updated

11 years ago
Component: OS Integration → Printing
Product: Firefox → Core
QA Contact: os.integration → printing
Version: unspecified → 1.8 Branch

Comment 1

9 years ago
I've got the same problem on my site and on other ones. They all work fine with explorer print option. The print out on firefox, edit the screen displayed but not more. Explorer print the whole URL page, even if it takes 5 pages of print.
From "/assets/css/screen.css", used by the URL referenced o

> /* = PRIMARY CONTENT
> -------------------------------*/
> 
> /*----------------*/
> /* BORDER TESTING */
> /*----------------*/
> body.homepage #primary-content { 
[SNIP]
> 	overflow:hidden;
> }

And, unsurprisingly, the div with ID "primary-content" is the one that contains all of the body content (which gets clipped at a page-boundary when printed/print-previewed).

--> Dupe of bug 129941
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129941
You need to log in before you can comment on or make changes to this bug.