Firefox 3 remote control steals foreground from other apps

RESOLVED DUPLICATE of bug 388664

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 388664
11 years ago
10 years ago

People

(Reporter: Jesus Cea, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112904 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112904 Minefield/3.0b2pre

When I "click" over a link in other program, the URL is opened in a Firefox windows/tab. The FF window goes to foreground, hiding the original application requesting the URL.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Open another program with URL link support
3. In the second program, "click" over a link
4. Firefox opens the URL
Actual Results:  
Firefox window goes foreground, stealing focus and visibility from the original URL requester.

Expected Results:  
Firefox should open the URL in background, leaving the original application alone. So the user can keep clicking on additional links, for example.

Previous versions of firefox worked fine. So, this is a regression.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: regression
Version: unspecified → Trunk

Comment 1

11 years ago
works for me - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007113004 Minefield/3.0b2pre ID:2007113004

Pidgin and Terminal
(Reporter)

Comment 2

11 years ago
Kevin, could you try with Thunderbird?. That is, click on a link in a message in Thunderbird.

Thanks.

Comment 3

11 years ago
I don't have Thunderbird installed.
Not blocking until it's confirmed.
Flags: blocking-firefox3?
(Reporter)

Comment 5

11 years ago
Some data:

I'm a KDE user. My version is a bit old: KDE 3.4.2. KDE standard windows manager. This is a Suse 10.0, fully patched.

I'm seeing this issue clicking links in Thunderbird 2.*.

My main point is: same configuration, Firefox 2 works fine.

Any other data you need?.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007121108 Minefield/3.0b2pre

Still reproducible.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2007121704 Minefield/3.0b3pre

Running on Gentoo under Gnome 2.20. Can confirm.
Also "Actual Results" i getting:
Firefox window goes foreground, stealing focus and visibility from the original
URL requester and keep flashing in taskbar.

Updated

11 years ago
Blocks: 140346
(Reporter)

Updated

11 years ago
Summary: Firefox 3 remote control stealths foreground → Firefox 3 remote control steals foreground

Updated

11 years ago
Blocks: 88810
No longer blocks: 140346
(Reporter)

Updated

11 years ago
Summary: Firefox 3 remote control steals foreground → Firefox 3 remote control steals foreground from other apps

Comment 9

11 years ago
I can also confirm this very annoying bug. Actually just for that i have set loadTabsInBackground or what it's called. If that config variable is true, it doesn't steal focus, but otherwise it does.

Very annoying when trying to open 10 links from an external feed reader with 

firefox -remote "openurl($URL,new-tab)"

and Firefox steals focus each time :(

I *think* when investigating the problem, i saw that content.focus() also raises the window, not just window.focus() as expected.

Firefox3 nightly on Linux with wmii window manager here.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 388664
You need to log in before you can comment on or make changes to this bug.