search bookmark titles and descriptions for url bar autocomplete

VERIFIED DUPLICATE of bug 393574

Status

()

Toolkit
Places
VERIFIED DUPLICATE of bug 393574
11 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

search bookmark titles and descriptions for url bar autocomplete

in a comment to a post on beltzner's blog, someone wrote:

"If only it would search bookmark names as well it would be perfect (hint hint)."

While we do search the uri title (in moz_places), we don't search the bookmark title (which can be different), or the microsummary title, or the bookmark description.

we could do all of that, but we might need a third row to show what we are matching on (in the case of description).

note, we should do global frecency first, as then once we get the chunk by frecency, we can join against annotations or bookmarks before doing search.
Perhaps treat the bookmark name as part of the page title and display as such. Whatever processes the title wouldn't even know it was actually a bookmark + title.

(cool bug) Bug 406246 – search bookmark titles and descriptions for url bar autocomplete
https://bugzilla.mozilla.org/show_bug.cgi?id=406246
In the latest location bar auto complete mockup (bug 393508), the bookmark title replaces the page title in the UI, and is searched against.  In the case that the bookmark title is different from the page title, and the page title has a match against the search query, perhaps we should display the matching text in the content line (which we are otherwise using for descriptions)?

Since the user entered the bookmark title, it is likely that they will both remember it and want to search against it.

Comment 3

10 years ago
Is it a duplicate of bug 393574?
We already search bookmark titles, so it's just descriptions/annotations, so this is a dupe of bug 393574.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Component: Places → Places
Product: Firefox → Toolkit
QA Contact: places → places
Resolution: --- → DUPLICATE
Duplicate of bug: 393574
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.