Closed Bug 406255 Opened 12 years ago Closed 12 years ago

emphasize the first matching text in both title and url

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta3

People

(Reporter: moco, Assigned: moco)

References

Details

Attachments

(2 files)

emphasize matching text in both title and url

right now, we underline the match in title, and if not title, then url.

we could (easily) underline the first match in both title and url, if that would be valuable.

note, underling all matches would not be so easy.
Blocks: 393508
No longer depends on: 393508
> note, underling all matches would not be so easy.

see bug #407944 and bug #407946
faaborg/beltzner, do we want this?
Summary: emphasize matching text in both title and url → emphasize the first matching text in both title and url
(In reply to comment #0)
> we could (easily) underline the first match in both title and url, if that
> would be valuable.

That indeed would be quite valuable to those who often are focusing on the URLs because the titles in the documents of interest are the same or very similar, or otherwise poor for discriminating among the hits (e.g., because one is seeking the set of documents with hits in a particular component of the URL fields, per se).  So if it could "easily" be done, please do it.

Attachment #294586 - Flags: ui-review?(beltzner)
Attachment #294586 - Flags: review?(gavin.sharp)
Attachment #294586 - Flags: review?(gavin.sharp) → review+
I think we want this, but it's up to the ux-folks.
Flags: blocking-firefox3?
yes, we definitely want this.
Attachment #294586 - Flags: ui-review?(beltzner) → ui-review+
Comment on attachment 294586 [details] [diff] [review]
patch

seeking approval for 1.9
Attachment #294586 - Flags: approval1.9?
Comment on attachment 294586 [details] [diff] [review]
patch

a=beltzner; I'll miss you most of all, scarecrow
Attachment #294586 - Flags: approval1.9? → approval1.9+
fixed.

Checking in toolkit/content/widgets/autocomplete.xml;
/cvsroot/mozilla/toolkit/content/widgets/autocomplete.xml,v  <--  autocomplete.xml
new revision: 1.105; previous revision: 1.104
done

adding litmus-? so that we remember to write some tests and so that QA knows about the change in the behavior.
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-litmus?
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M11
Assignee: nobody → sspitzer
please note that when the match is due to a tag, the matching text in neither title nor url are emphasized.

That was by design, but perhaps that should be revisited.  see bug #411963
in-litmus+:

https://litmus.mozilla.org/show_test.cgi?id=5117

Verified FIXED using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008011504 Minefield/3.0b3pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008011504 Minefield/3.0b3pre

and

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008011504 Minefield/3.0b3pre

I'm not verifying the full algorithm; just that we now match both title and URL...
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Flags: blocking-firefox3? → blocking-firefox3+
You need to log in before you can comment on or make changes to this bug.