Closed Bug 406304 Opened 14 years ago Closed 14 years ago

Browser window comes to foreground while loading a page

Categories

(Core :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: mcsmurf, Unassigned)

References

Details

(Keywords: regression)

To reproduce:
1. Open two new browser windows
2. Load http://www.heise.de in the first window
2. Load any page in the second window
3. Press F5 to reload the first page in the first window
4. Quickly switch to the second window and wait

Note how the first window now comes to the foreground again when it updates the page it is reloading. In the task bar the second window is still shown as active though, the first window just comes to the foreground, but does not get focus.
This is a regression, probably happened around 2007-11-28 according to Bug 405899 Comment 21.
This problem first shows up in 20071128_1228_firefox-3.0b2pre.en-US.win32.zip.
What does that file name mean (it's no official file name)? Especially the _1228_?
Those are probably hourly builds from http://hourly-archive.localgho.st/
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1196280540&maxdate=1196281679
I see a similar issue with the same regression range: when I click on a toolbar button which opens the Places window (or the Add-ons window) and I leave my mouse on the button after clicking, the window disappears suddenly to the background when I move my mouse a few pixels. 
Very likely that Bug 395334 has caused this bug here. Marking dep.
Blocks: 395334
(In reply to comment #3)
> Those are probably hourly builds from http://hourly-archive.localgho.st/
> http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1196280540&maxdate=1196281679
> I see a similar issue with the same regression range: when I click on a toolbar
> button which opens the Places window (or the Add-ons window) and I leave my
> mouse on the button after clicking, the window disappears suddenly to the
> background when I move my mouse a few pixels. 
> 

That is correct. For several months now Peter(6) has provided a link in the daily Trunk threads so that testers can get to the hourly builds for the previous 14 days and locate which hourly build is the first one where a bug occurs aka finding the regression range. What is provided there are the zipped versions of the hourly builds needing only to be extracted to be ready to run.

As to deciphering the file name, 20071128_1228_firefox-3.0b2pre.en-US.win32.zip, this build was made on November 28, 2007 and I am guessing that it began as 12:28 Pacific Standard Time using a 24-hour clock, not 12-hour. It is a Firefox 3.0 pre beta 2 version for windows (win32) in US English (en-US).

If you go to the link that Ria provides (link: http://hourly-archive.localgho.st/), go to the 20071128 Builds link and click on it. Beside the cited build you will find a link to Cached Checkins (link: http://hourly-archive.localgho.st/win32/20071128_1228_checkins.html) for that specific build. For that build, it appears 5 patches landed in it including the one Frank cited, Bug 395334.

Hope this helps clear up any confusion.
I can't reproduce this bug anymore; fixed by the patch of Bug 405899 I assume.
I assume so, too. And it's also fixed here.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: 405899
Resolution: --- → FIXED
(In reply to comment #6)
> I can't reproduce this bug anymore; fixed by the patch of Bug 405899 I assume.
> 

I have not seen the problem since Bug 405899 landed, too.
You need to log in before you can comment on or make changes to this bug.