Closed Bug 406361 Opened 14 years ago Closed 14 years ago

Large leak with <svg:use patternTransform>

Categories

(Core :: SVG, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9beta2

People

(Reporter: jruderman, Assigned: peterv)

References

(Blocks 1 open bug)

Details

(Keywords: memory-leak, regression, testcase)

Attachments

(2 files)

Attached file testcase
Loading the testcase makes Firefox leak nsGlobalWindow, nsDocument, BackstagePass, and more.

Regression from bug 405639?
Flags: blocking1.9?
Attached patch v1Splinter Review
Grrrr, too many macros.
Assignee: nobody → peterv
Status: NEW → ASSIGNED
Attachment #291055 - Flags: superreview?(jonas)
Attachment #291055 - Flags: review?(jonas)
Attachment #291055 - Flags: superreview?(jonas)
Attachment #291055 - Flags: superreview+
Attachment #291055 - Flags: review?(jonas)
Attachment #291055 - Flags: review+
Attachment #291055 - Flags: approval1.9+
+ing because it is a mlk...
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Flags: in-testsuite?
OS: Mac OS X → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.