Memory usage continues to increase when using sites like cbsnews.com or cnn.com which refresh

RESOLVED INCOMPLETE

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Mark Beifuss, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-10])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071106 Firefox/2.0.0.9 Flock/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071106 Firefox/2.0.0.9 Flock/1.0.1

Memory consumption is currently 1.27GB (1270MB) for 10 tabs of which 8 are static and 2 are refreshed (cbsnews.com, marketwatch.com).  This program has been running for only 4 days. 

Reproducible: Always

Steps to Reproduce:
Steps to reproduce bug:

  1. open a few tabs with with refresh like marketwatch.com usatoday.com cnn.com or cbsnews.com.  May just be any web page.
  2. let it run for a few days.
  3. look in taskmanager


Actual Results:  
Actual Result: What started out as 100 mb of memory with 8 or 9 tabs (you gotta be kidding (it's just text and small graphics) has turned into 1.27GB of memory.  As you would expect my system performance is in the toilet.  I also noticed this with firefox (I believe you are using the same engine).  This occurred in 4 days of use.  It will continue to climb (memory leak) until I run out of memory (physical + virtual) or I shut it down.

Expected Results:  
Expected Result: reasonable memory requirements.  No slow down of in accepting keyboard input, no system performance penalty


Memory requirements shouldn't be that high on startup either.

Comment 1

8 years ago
mark, do you see this also with Firefox 3.6 started in safe mode and newest flash version?
 http://support.mozilla.com/kb/Safe+Mode

if you do not, please close the bug with resolution set to WORKSFORME. Or, if you determined the issue is related to an add-on, please set resolution to INVALID.
Whiteboard: [closeme 2010-05-10]
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.