Closed Bug 40661 Opened 20 years ago Closed 20 years ago

"files" datasource fails to open non-latin named directory

Categories

(Core :: Internationalization, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED DUPLICATE of bug 28787

People

(Reporter: mik, Assigned: ftang)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000524
BuildID:    2000052420

If I have any russian-named directory and try to browse it with
"files" datasource (file:// url, or even this url bookmarked, then instead of a
directory content I have a content of a root directory for that drive

Reproducible: Always
Steps to Reproduce:
1. open file:///c:/ url
2. find any non-latin named directory and try to open it with an arrow
3. see a content of a root directory there another content should be

Actual Results:  Currently, I get structure like this:
c:\
c:\a
c:\a\non-latin
c:\

Expected Results:  I should see a content of a non-latin directory
this should probably go to rjc.

*** This bug has been marked as a duplicate of 28787 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Verified as Dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.