Right floated block content pushed down by inline content.

RESOLVED DUPLICATE of bug 50630

Status

()

RESOLVED DUPLICATE of bug 50630
11 years ago
11 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Gecko behaviour agrees with Internet Explorer 6 - but disagrees with Konqueror, Safari and Opera.
On this page, the left text (blue coloured border) is styled display: inline; the right div (red coloured border) is float: right.
The expected behaviour was for the right floated content to be aligned with top of page and inline text.

In IE and Firefox, this did not occur, instead, the floated block was pushed down by the line height.

If the order of the div and the inline element are reversed on the page, the float occurs as expected.

Looked around for existing bugs before filing, but feel free to dupe.
Bothers me more that this behaviour is inconsistent with the other standard browsers.
IE, I am used to working around with conditional comments.  Firefox, is more difficult to work around.  I have to use Gecko specific pseudo-classes.
(Reporter)

Updated

11 years ago
OS: Linux → All

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 50630
You need to log in before you can comment on or make changes to this bug.