Location bar text sticks in new tab, switched tab

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: ray, Unassigned)

Tracking

2.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

I believe this started about a month ago. I am surprised I do not see any bugs in the system about it. I saw it on at least 2.0.0.10 and I still see it on 2.0.0.11.

Say that I have a window and the URL in the location bar is "https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox". I can create a new tab and I get the blank tab content, but the URL still says the same in the location bar. I think that the location bar should be empty. I can switch between existing tabs by licking on the tabs and the location bar shows the last URL loaded, regardless of which tab I am in.

I can click on the re-load in a tab and it puts the correct URL into the location bar and re-loads the page.

This happens, for me, on all web pages.

This does not occur on my local build of the trunk (from 20071202_202630_PST).
I can't reproduce this.  (I tried in Firefox 2.0.0.11 on Windows and
Linux, and in both Firefox 2.0.0.9 and Firefox 2.0.0.11 on the Mac.)

Are you missing some steps?  Does the problem still happen with a
fresh profile?
(Reporter)

Comment 2

11 years ago
Urf. I see it. Then I run with a clean profile and I do not. Then I run with old profile and I see it. Then I disable all add-ons and I do not see it. Then I re-enable all add-ons (in bunches) and I do not see it. Quit and launch a few more times and I see it again. I hate this kind of thing.

I will have to get some verbose output going and see if I see anything that might tell me what the heck it is doing.
This kind of behavior is usually indicative of a thrown exception in the global window scope. Setting javascript.options.showInConsole to true using about:config, and the looking for Errors in the Error Console when it happens should help you pinpoint the faulty exception.
(In reply to comment #3)
> pinpoint the faulty exception.

Er, I meant "faulty extension", of course :)
(Reporter)

Comment 5

11 years ago
Thanks for the reminder. Double-checked and I do have that set. I will keep my eyes open for it.

Updated

11 years ago
Blocks: 410439
No longer blocks: 410439

Comment 6

10 years ago
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090119 Minefield/3.2a1pre
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.