ICS remote (http) calender created OK but never reloaded (automaticly or manually)

RESOLVED DUPLICATE of bug 338527

Status

--
major
RESOLVED DUPLICATE of bug 338527
11 years ago
11 years ago

People

(Reporter: erik, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc7 Firefox/2.0.0.9
Build Identifier: 0.8pre 2007120403

After initially being created OK the calendar cannot be loaded again after thunderbird has been restarted.

Reproducible: Always

Steps to Reproduce:
1. Create remote ICS calendar with existing ics url containing calender data
2. Lightning now shows the calender + data
3. Exit thunderbird
4. Start thunderbird
5. Calendar is empty
6. Reload (either the button, ^R or right click on the calender+reload) does not show any activity and the calender remains empty

Actual Results:  
No calendar data, no reload.

Expected Results:  
The actual calendar data (appointments).

Please note the sunbird does work on this calendar.

The ics url is http://artemis.slagter.name/dav/calendar.ics

This will not work from "outside" as this is an internal address.

The calender is contained inside a webdav-enabled directory (apache) + basic http authentication required. I already tried to place the file into a test directory with no webdav and no authentication; no difference.

Strace -f on thunderbird does not reveal any significant activity when asking for a reload, it seems that thunderbird/lightning doesn't even try.
Any calendar related error messages in the Error Console?
(Reporter)

Comment 2

11 years ago
Nope :-(

Comment 3

11 years ago
I have exactly the same problem! My client is Windows XP sp2 with Thunderbird 2.0.0.12 and Lightning 0.8, server where I have put the file ics is a linux Debian etch rel 4.0 with Apache2 2.2.3-4+.
WebDav directory don't have any kind of authentication and permission is read/write/access for all user.
I had the same problem also with 0.7 version of lightning.
Bye. 

Comment 4

11 years ago
Could this bug be somehow related to bug 373439?

Comment 5

11 years ago
@Decathlon, it seems unlikely at that bug is about caldav, not webdav. How are your proxy-configurations? Could you retest with the latest nightly build of lightning, there have been some changes which maybe resolved this issue (bug 338527).
(Reporter)

Comment 6

11 years ago
(In reply to comment #4)
> Could this bug be somehow related to bug 373439?

Although the access mechanism is different I really think this actually is the same bug.

I seem to remember (from when I used ical, I am using google calender now) that unsetting the proxy made the bug disappear.
(Reporter)

Comment 7

11 years ago
(In reply to comment #5)
> @Decathlon, it seems unlikely at that bug is about caldav, not webdav. How are
> your proxy-configurations? Could you retest with the latest nightly build of
> lightning, there have been some changes which maybe resolved this issue (bug
> 338527).

This is another bug I know well from pre-0.7 versions.

With a post-0.7 version the calender can't be loaded in any way.

Comment 8

11 years ago
Confirm to Erik.
I tried to set proxy configuration to "manual mode" or "no proxy" and the bug disappear.
Only when proxy configuration is set to autoconfiguration the bug persist.
Resolving as duplicate per previous comment. It would be nice if you could retest with a recent Sunbird/Lightning 0.9pre nightly test build. (But don't forget to backup your profile data first.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338527
You need to log in before you can comment on or make changes to this bug.