If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fails to start Netscape or Messenger

VERIFIED DUPLICATE of bug 40762

Status

Core Graveyard
Profile: BackEnd
P3
blocker
VERIFIED DUPLICATE of bug 40762
18 years ago
2 years ago

People

(Reporter: fenella, Assigned: selmer (gone))

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux (2000-05-26-08 M16)
Steps:
1. Download and start the commercial build
2. Type ./netscape or ./netscape -mail
3. When Manage User Profile dialog comes up, select a profile
4. And click on Start Netscape
Actual result:  The Start Netscape button got depressed and got hung up. No
browser (or Messenger) comes up. If I drag the dialog, it traps the garbage.
Expected result: It should bring up the Browser (or Messenger)

My machine is Linux 6.0. I tried it on Karen's machine, which is also 6.0, we
see the same problem. However, on Esther's Linux 6.1, she does not have the same
problem

I tried to use old profile, new profile and repeatedly tried it 4-5 times, it
does not help. 

This is a blocker.

Comment 1

18 years ago
We use Redhad Linux 6.0.  I tried my machine and Charles's machine (both are 
6.0).  I was able to start Netscape or Messenger on both machines.  

Comment 2

18 years ago
fyi: I/m able to launch mail in my linux system 6.1.

Comment 3

18 years ago
Fenella, can you try yesterday's build? Want to narrow down when this problem
started happening.
Hardware: Sun → PC
i see this problem on my RH 6.1 machine, hopey. this is what i experienced:

0. got rid of existing .mozilla directory.
1. downloaded the netscape tarball (this am's comm bits, 2000.05.26.08-m16).
2. extract it using tar zxvf.
3. go into the package dir, and attempt to launch it using ./netscape

results: get the following console msgs, but *nothing* launches (no profile mgr
stuff, no browser window, nothing).

sairuh@hopey 24: ./netscape
.//run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/u/sairuh/seamonkey/00052610/package
 
LD_LIBRARY_PATH=/u/sairuh/seamonkey/00052610/package/Cool:/u/sairuh/seamonkey/00052610/package:/u/sairuh/linux/seamonkey/package
         
LIBPATH=/u/sairuh/seamonkey/00052610/package:/u/sairuh/seamonkey/00052610/package/Cool
      
SHLIB_PATH=/u/sairuh/seamonkey/00052610/package:/u/sairuh/seamonkey/00052610/package/Cool
      XPCS_HOME=/u/sairuh/seamonkey/00052610/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
*** Deferring registration of sample JS components
*** Registering sample JS components
nNCL: registering deferred (0)
nNCL: registering deferred (0)
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
ProfileManager : CreateNewProfile
Profile Name: default
Profile Dir: /u/sairuh/.mozilla
before SetProfileDir
ProfileManager : CreateUserDirectories
after SetProfileDir
ProfileManager : GetProfileDir
ProfileManager : GetProfileDir

Startup homepage http://home.netscape.com/
this totally blocks me. it wasn't a problem using wednesday's builds. will try
using y'day's.
Keywords: dogfood, nsbeta2, pp

Comment 6

18 years ago
per granrose, reassign to profile mgr backend since the hangup seems to be in
that part of the code
Assignee: asadotzler → selmer
Component: Browser-General → Profile Manager BackEnd
QA Contact: jelwell → gbush

Updated

18 years ago
Component: Profile Manager BackEnd → Browser-General
Keywords: dogfood, nsbeta2, pp
QA Contact: gbush → jelwell

Comment 7

18 years ago
This problem is not occurring on 05-24-08-M16 commercial build but it did 
occurred on 05-25 & 05-26 commercial build for the local user account 
environment.
I believe there are some changes between 05-24 & 05-25 build.
Kind of some environmental,configuration or path setting changes....
(Reporter)

Comment 8

18 years ago
Lisa, I saw this problem in yesterday's Linux build too. Since Suresh passed the 
build yesterday and it was late, I just waited for today's build to finally log 
a bug.  This bug also occurs on Ninoschka's machine.

Seth has come to my machine and found that there indeed exists some directory 
path problem, he said he would look into it.

Component: Browser-General → Profile Manager BackEnd
Keywords: dogfood, nsbeta2, pp
QA Contact: jelwell → gbush
i wonder...could this be related to bug 5132? this is not a problem using the
mozilla bits, so adding nsonly kw.
Keywords: nsonly

Comment 10

18 years ago
This is a dup probably of http://bugzilla.mozilla.org/show_bug.cgi?id=40762.

Comment 11

18 years ago
This definitely is a dup of 40762. Neeti has backed out her changes this 
afternoon at around 3.47. Upcoming builds should work just fine if not horked by 
other problems.

*** This bug has been marked as a duplicate of 40762 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
ok
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.