No selection highlight in "Find text" entry box in "Find in the Page" dialog

VERIFIED DUPLICATE of bug 40006

Status

P3
minor
VERIFIED DUPLICATE of bug 40006
19 years ago
14 years ago

People

(Reporter: sidr, Assigned: law)

Tracking

({polish})

Trunk
x86
Windows NT
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
While it is possible to select all or part of the text in the "Find text"
editbox in the "Find in the Page" dialog, there is no visual feedback
(highlight) to show that a selection has been made.

Steps to reproduce:
1. Invoke Search>Find on this Page
2. Type several characters.
3. Press [Shift], hold, press [Left], let [Shift] key up.
4. Press [Delete].
5. Drag from a point inside the editbox to the right of the text
   to the beginning of the editbox, release mouse.
6. Press [Delete].

Expected Results:
In steps 3 and 5, the rightmost and all of the remaining characters,
respectively, will appear hightlighted; in steps 4 and 6, those
characters will be deleted.

Actual Results:
In steps 3 and 5, characters will be selected but not higlighted; in steps 4 
and 6, those characters will be deleted.

Other Information:
The same problem is apparent when a "Find in the Page" dialog is brought up
again, with text persisting in the editbox from earlier use; in this case,
it looks like it is impossible to clear that text, although [Backspace]
works just fine.

Tested with:
the 2000-05-25-08-M16 nightly binary on WinNT
(Reporter)

Updated

19 years ago
Keywords: polish

Comment 1

19 years ago
Polish it in M21.
Assignee: matt → law
Target Milestone: --- → M21

Comment 2

19 years ago
Find does not equal Search. sidr, you know better! Changing component and QA
Component: Search → XPApps
QA Contact: claudius → sairuh

Comment 3

19 years ago
This is a dup of Bug 40006.
(Reporter)

Comment 4

19 years ago
And so it is; marking as DUP. And yeah, I know enough to look at the components
list if I have *any* doubt, but in this case I'd never have expected "Search"
to be narrowly defined -- but that's the blackbox user perspective for you.

*** This bug has been marked as a duplicate of 40006 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
vrfy dup.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.