Images with transparent backgrounds are garbled when printed

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: wgianopoulos, Assigned: vlad)

Tracking

({regression, testcase})

Trunk
x86
Linux
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

11 years ago
Created attachment 292090 [details]
image that shows the issue when printed

Since the latest Cairo upgrade, images with transparent backgrounds no longer print correctly under Linux.  Print preview displays correctly.

The problem does not seem to be present under Windows.
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
Created attachment 292094 [details]
how this looks when printed

Updated

11 years ago
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Created attachment 292640 [details]
print-to-file results

If I tick "Print to file" in the print dialog, this is what I get in FF3.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007121008 Minefield/3.0b2pre

In FF2, I get a nice postscript printout.
Created attachment 292641 [details]
screenshot of print-to-file
Assignee: nobody → vladimir
Created attachment 294809 [details]
Image #2

I'm guessing I'm seeing the same bug with this image.
Created attachment 294810 [details]
Screenshot of Image #2

This is what it looks like when printed.  Note that it displays correctly
in Print Preview.  The problem only occurs on Linux.
Fixed upstream:

commit c621d8d7191bfa8c1bca533bf9d53d514d01f529
Author: Vladimir Vukicevic <vladimir@pobox.com>
Date:   Fri Jan 25 15:01:44 2008 -0800

    [ps] Pad image mask lines out to full lines
    
    The PostScript backend was generating image masks with packed mask
    bits, when PS seems to expect each line of the mask to be padded out
    to 8 bytes.
    
    Ref: https://bugzilla.mozilla.org/show_bug.cgi?id=407360

Depends on: 413878
Duplicate of this bug: 408210
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.