Site hangs browser and spins CPU

RESOLVED WORKSFORME

Status

()

Core
General
--
major
RESOLVED WORKSFORME
11 years ago
4 years ago

People

(Reporter: Steve Wardell, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Accessing the site above causes the CPU usage to max out. This does not occur in FF 2.0.0.11. I am using daily build 2007120705 on XP.
Flags: blocking-firefox3?
view-source:http://www.trans4mind.com/personal_development/JavaScript/longnumMultiply.htm is safer to click on to investigate.

Moving to JS engine ...
Assignee: nobody → general
Component: General → JavaScript Engine
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: general → general
Looks like that's just infinite recursion, possibly with DOM munging involved... I do get two "slow script" dialogs, and cancelling them both lets the page eventually load. Can you find a regression range, using "trunk" builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ ?
Assignee: general → nobody
Component: JavaScript Engine → General
Keywords: qawanted
QA Contact: general → general
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007121000 Minefield/3.0b2pre

WFM
(Reporter)

Comment 4

11 years ago
Confirmed, WFM. It looks like something got fixed in the builds the last few days to correct this.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Issue is Resolved - removing QA-Wanted Keywords - QA-Wanted query clean-up task
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.