Unexpected behaviour with separators and bookmark folders

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Eric Schwartz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007120704 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007120704 Minefield/3.0b2pre

If I right-click on a folder in the Bookmarks Toolbar, I cannot create a separator by choosing New Separator.  If I right-click on a bookmark, then I can create a separator.  

If I right-click on a folder in the Bookmarks menu and select New Separator, I create a separator within the folder, not at a sibling level.

If I right-click on a folder in the Bookmarks Sidebar or Places Organizer, New Separator creates a separator just below the folder I was right-clicking on.  I would prefer this behaviour everywhere.

Reproducible: Always

Steps to Reproduce:
1. See Details.
2.
3.
Actual Results:  
Can't create a separator from right-clicking on a folder in the toolbar.
Can't create a separator at the same level of a folder in the Bookmarks menu.

Expected Results:  
Can create a separator in the toolbar.
Separator is created at the same level as the folder in the Bookmarks Menu

I like pie.
(In reply to comment #0)

> 
> If I right-click on a folder in the Bookmarks Toolbar, I cannot create a
> separator by choosing New Separator.  If I right-click on a bookmark, then I
> can create a separator.  
>
This is working fine here on Windows XP (at least it creates a separator inside the folder where I right clicked on)
 
> If I right-click on a folder in the Bookmarks menu and select New Separator, I
> create a separator within the folder, not at a sibling level.
>
The same here
 
> If I right-click on a folder in the Bookmarks Sidebar or Places Organizer, New
> Separator creates a separator just below the folder I was right-clicking on.  I
> would prefer this behaviour everywhere.
>
I would also expect this. In any case it is inconsistent. 
See also bug 403263 about deleting separators.
Status: UNCONFIRMED → NEW
Component: Build Config → Places
Ever confirmed: true
OS: Linux → All
QA Contact: build.config → places
Hardware: PC → All
Version: unspecified → Trunk
actually default insertionpoint is BEFORE item, and all cases above are working like that
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081123 Minefield/3.1b2pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 470391
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.