[10.4, 10.5] Saving as PDF when printing fails to suggest the page title as a filename for the first print

RESOLVED FIXED in Camino2.0

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: alqahira, Assigned: stuart.morgan+bugzilla)

Tracking

unspecified
Camino2.0
PowerPC
Mac OS X

Details

(URL)

On 10.4, this used to work properly (on 10.3, it worked properly unless you hit bug 303547).  However, currently on 10.4 and 10.5, the first time you save a PDF, Camino fails to suggest the page title as a filename.

Sam, Chris, and I all looked at this, and we get inconsistent results as to *what* we suggest.  On trunk, Sam always gets ".pdf" suggested.  Chris gets a mix of "Untitled.pdf" and ".pdf.pdf".  On trunk, I get "Untitled.pdf", and on branch I get a mix of "Untitled.pdf" and ".pdf.pdf".

STR:

1) Launch Camino (branch or trunk) with a fresh profile
2) http://www.google.com
3) Cmd-P, Save as PDF
4) Observe the filename (and on 10.5, the Title metadata)
5) Save anyway
6) Repeat step 3
7) Repeat step 4

ER: Steps 4 and 7 both suggest "Google.pdf"
AR: Step 4 suggests something else, step 7 suggests "Google.pdf"

I have no idea when this regressed, but I know smfr made it work right at one point and it worked fine on 10.4, because we tagged 303547 10.3-only.
Flags: camino1.6?
(Assignee)

Comment 1

11 years ago
This should be retested in tomorrow's trunk build, as the checkin for bug 312018 likely fixed this.

Comment 2

11 years ago
With a post-312018 build: 2.0a1pre (1.9b3pre 2008011016) this seems to work fine here; with 10.4.11 ppc.
Seems FIXED here on 10.5/Intel with the tinderbuild, too.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b3pre) Gecko/2008011019 Camino/2.0a1pre (like Firefox/3.0b3pre)
Assignee: nobody → stuart.morgan
Depends on: 312018
(Assignee)

Comment 4

11 years ago
Sounds FIXED then. Removing the 1.6? flag since the branch request is being tracked in 312018.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: camino1.6?
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → Camino2.0
You need to log in before you can comment on or make changes to this bug.