Status

()

Core
General
RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: Dwight Potvin, Unassigned)

Tracking

1.8 Branch
x86
Windows Vista
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment 20 for a list of possible reasons])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

No matter what I am running, there is no sound that comes from firefox. I have sound through every thing else including IE, but say like I am on youtube, there is no sound coming from the videos, but yet when I am using a messanger type thing like meebo, sound still can go out.

Reproducible: Always

Steps to Reproduce:
1.Just Opening Firefox
Actual Results:  
No sound.

Expected Results:  
Produced Sound When Running Something With Sound/

It is not the computer, because if it was there would be no sound throughout everything on my computer not just firefox.
Component: Installer → General
Product: Firefox → Core
QA Contact: installer → general
Version: unspecified → 1.8 Branch
(Reporter)

Comment 1

10 years ago
Also while i remember, OI have also tried to uninstall firefox and reinstall it and it didn't work.

Comment 2

10 years ago
I don't think this is a problem with Firefox. If it affects everything in FF not just YouTube, it could be down to a Windows Sound Mixer blocking sound from FF or if not; if it's just YouTube it will be an in built mute in YouTube.

It's all working fine for me and I am running the same system as you; though I could be wrong I don't think it's FF.
(Reporter)

Comment 3

10 years ago
NO its not just youtube, there is no sound at all when using firefox, and i have check any and all sound systems and i can't see where it would be blocked, let alone how it could be..so if you think it is blocked then give me ideas where to look because i'm clueless.
(Reporter)

Comment 4

10 years ago
Ah ya umm, when i click into the Mixer it has sound setting for the Speakers, and Windows Sound, and IE when i'm using it, but Firefox doen't show, so it might be blocked, anyone have an idea how i can fix it if thats the problem?

Comment 5

10 years ago
Get Firefox open first, then open the Mixer and check to see what the volume's like for Firefox.
(Reporter)

Comment 6

10 years ago
There is nothing for it shown. It just says "Speakers", "Windows Sound", "Speech Recognition", and "Communication Manager"

Comment 7

10 years ago
Ive exactly same problem.
NO SOUND only on FF... no reason, make me very mad.
No fix.. no idea, nobody can help us ?? 
Its amazing... why only FF ? suddently.. before it worked good, and one day... nothing, no sound...

Comment 8

10 years ago
I have the same problem in Firefox 3 Beta 5 on Windows XP.
After some browsing the sound in Firefox disappears (YouTube, GMail chat, etc.). I don't have a clear way to reproduce this, but it happens fairly often. If I restart Firefox sound works again.

Comment 9

10 years ago
The only add-on I have installed is Personas for Firefox.

Updated

10 years ago
Flags: blocking1.9?
We can't block on unconfirmed bugs, and I would expect to have gotten way more duplicates if this issue were affecting users broadly.

What version of Firefox are you running? Can you try nightly builds? What version of Flash are you using (go to about:plugins to find out) Have you updated your Flash plugin?

Renominate if you have new information. Thanks!
Flags: blocking1.9? → blocking1.9-

Comment 11

10 years ago
As I said, I'm using Firefox 3 Beta 5 on Windows XP.
Shockwave Flash
    File name: NPSWF32.dll
    Shockwave Flash 9.0 r115

Comment 12

10 years ago
Hello.

I also have the same problem!

I was writing it on Bug#410825.

I thought that the problem will solved after I made the update for Ver.3... and it wont solved, and my other bugs did not also.

my addons are:
AdBlock Plus - 0.7.5.5
AVG Safe Search - not working
Download Accelerator Plus Integration - 8.0.6.5
HideIP 1.0
IDM CC 5.3
NoScript 1.6.9.3
OpenSearchFox - 0.1.5
Personas for Firefox - 0.9.2
SafeCache - 0.9 - Not working
SafeHistory - 0.8 - Not working
TrackMeNot - 0.5.32 - Not working

And my browser language is Hebrew.

I sew that Bagdan Stroe also have the Personas for firefox...

maybe it causes the problem?

thanks!!

Comment 13

10 years ago
I use Windows Vista and I have the Firefox 3 browser.  I can confirm I have no sound on ANY Flash based applications (youtube, facebook chat, ANY facebook application, and ALL media type embedded videos.  There is no way to reproduce.  For while I had no sound with just youtube, but I realized it was after having more than 10 youtube vids on a page.  So, I would avoid, but now after d/l'ing the new firefox 3.  All flash, wmp, realplayer, etc do not have sound at all.  

I can get sound when I have a standalone media player, but if anything is attached on a website ... no sound.  none.

Comment 14

10 years ago
I am using windows xp and I also have no sound. I loaded firefox 3.
My sound card is an Realtek ac97 VIA, comp a T3302 (no snickering).

Hope someone is working on this.  

Comment 15

10 years ago
Confirming on FF 3.0.1 Windows XP, english (UK)

Comment 16

10 years ago
Vista FF 3.0.1 and not working here. Works fine for maybe half a song and then good bye. 

Comment 17

10 years ago
No sound again in 3.1 (TraceMonkey) on Mac.

Comment 18

9 years ago
You see the problem when using flash v10?
No trouble here with flash v10 and vista or XP.

Comment 19

8 years ago
(In reply to comment #18)
> You see the problem when using flash v10?
> No trouble here with flash v10 and vista or XP.

I had the same trouble with flash v10 on windows7.
However, I click the Mixer, when a flash video is going on, the trouble is resolved.

Comment 20

8 years ago
Thank you all for your reports, but the browser doesn't control the sounds from flash in any way.

To troubleshoot this, first try restarting the browser / rebooting the computer and if the problem doesn't come back, sigh with relief :)

Otherwise, from a brief bugzilla and google search, the lack of sound is likely caused by:
1) outdated flash version (at least some people claim that it got fixed after updating flash - e.g. bug 501946). You shouldn't use outdated Flash anyway, it will cause instability and may be cause of virus infection.
2) On Windows Vista / 7 check the sound mixer settings (while the video with sound is playing!), it allows to mute specific application.
[from http://ask.metafilter.com/44838/No-Flash-sound-in-Firefox]
3) apparently there's a program called FlashMute that can mute flash, make sure you it's not installed.
4) there's also a "fix" with tweaking the registry. Use at your own risk (at least back up that portion of registry); some people claim it fixed the problem for them.

Resolving this bug, since, as I said, there's probably nothing we can do about it anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Summary: NO Sound → No sound from Flash
Whiteboard: [see comment 20 for a list of possible reasons]

Updated

8 years ago
Duplicate of this bug: 410825
You need to log in before you can comment on or make changes to this bug.